Bug 45112 - Netscape 4.77 fails on bugzilla pages due to missing .js files
Summary: Netscape 4.77 fails on bugzilla pages due to missing .js files
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: bugzilla (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: noarch Linux
medium
medium
Target Milestone: ---
Assignee: Tim Powers
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-20 09:51 UTC by Toralf
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-11 11:31:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Toralf 2001-06-20 09:51:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.5-0.2.9 i686)

Description of problem:
<script src="localconfig.js"></script>

and

<script src="quicksearch.js"></script>

in bugzilla .html files cause trouble for Netscape because localconfig.js
are missing quickseach.js (they are not included with bugzilla.)

I don't see this problem with mozilla/galeon; they appear to ignore the
missing files.

How reproducible:
Always

Steps to Reproduce:
1. netscape http://<bugzilla host>/bugzilla
2.
3.
	

Actual Results:  Netscape complained about missing http://<bugzilla
host>/bugzilla/localhost.js first, then .../quicksearch.js when it was
created. Netscape crashed shortly after this.

Expected Results:  Bugzilla main page opened

Additional info:

bugzilla package upgraded via link in entry for bug no 19497.

Comment 1 Toralf 2001-06-20 09:59:12 UTC
The page loads correctly after

touch /var/www/html/bugzilla/localconfig.js
/var/www/html/bugzilla/quicksearch.js

but somehow transfer is slowed down significantly. Removing script tags is
better.

Comment 2 Tim Powers 2001-06-27 20:54:36 UTC
Please try using the bugzilla located here:

http://people.redhat.com/timp/RPMS/bugzilla-2.12-3.noarch.rpm

Let me know whether this works for you or not.

Tim

Comment 3 Toralf 2001-06-28 09:37:22 UTC
It looks better now. All files appear to be there, and quick search works just
fine.

I still get a failed dependency during install though. You should probably do

%install
[...]
%__install -d -m 775 %{buildroot}/usr/bonsaitools/bin
%__ln_s /usr/bin/perl %{buildroot}/usr/bonsaitools/bin
[...]

%files
%config(noreplace)/usr/bonsaitools/bin

or something like that.


Comment 4 Tim Powers 2001-09-11 11:31:00 UTC
The new package I just release as an errata should fix this.

Tim


Note You need to log in before you can comment on or make changes to this bug.