Bug 451173 - yum update hangs every time
yum update hangs every time
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-13 04:01 EDT by Allan Engelhardt
Modified: 2014-01-21 18:03 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 14:33:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated packages (11.39 KB, text/plain)
2008-06-13 04:01 EDT, Allan Engelhardt
no flags Details

  None (edit)
Description Allan Engelhardt 2008-06-13 04:01:37 EDT
Description of problem:

yum update hangs and the only way to end the process is by 
# kill -9 $(cat /var/run/yum.pid)

Version-Release number of selected component (if applicable):
yum-3.2.16-2.fc9.noarch

How reproducible:
Always


Steps to Reproduce:
1. 
# yum --verbose --noplugins update
Config time: 0.148
Yum Version: 3.2.16
COMMAND: yum --verbose --noplugins update 
Installroot: /
Reading Local RPMDB
rpmdb time: 0.000
Setting up Package Sacks
Excluding Packages in global exclude list
Finished
pkgsack time: 0.926
Setting up Update Process

2. Wait to see that nothing more happens.
3. Try SIGINT (^C), SIGQUIT (^\), kill $(cat /var/run/yum.pid), kill -15 $(cat
/var/run/yum.pid) and similar before you fall back on kill -9 $(cat
/var/run/yum.pid)

Doing a yum clean all first makes no difference.  Network connectivity and such
are of course fine.
  
Actual results: Process hangs


Expected results: Process completes.


Additional info:
This is a new problem after I installed this week's updates and rebooted the
system.  The list of updated packages (extract from yum.log) is attached.

THis may be an underlying rpm problem, but yum shouldn't just hang with no output.
Comment 1 Allan Engelhardt 2008-06-13 04:01:37 EDT
Created attachment 309180 [details]
Updated packages
Comment 2 Allan Engelhardt 2008-06-13 17:15:28 EDT
This appears to be a bad interaction with PackageKit.  Booting to runlevel 3 and
removing the gnome-packagekit package appears to fix the problem for me.

(But I still think yum should tell me what the problem is....)
Comment 3 Allan Engelhardt 2008-06-13 17:17:41 EDT
(In reply to comment #2)
> This appears to be a bad interaction with PackageKit.  Booting to runlevel 3 and
> removing the gnome-packagekit package appears to fix the problem for me.

Said that too quickly.  I am unable to use yum under Gnome / X Windows.  Does
yum use dbus anywhere?
Comment 4 Allan Engelhardt 2008-06-13 18:00:41 EDT
After (further) erasing yum-packagekit (and the dependent package PackageKit) I
am able to use yum again in a gnome-terminal.
Comment 5 Seth Vidal 2008-06-16 14:33:19 EDT
yum doesn't use dbus but packagekit does. If you want to re-enable/install it
and file this bug under packagekit I'm sure they'd appreciate it.

otherwise I'm just going to close it.

Note You need to log in before you can comment on or make changes to this bug.