Bug 451177 - wrong newlines when downloading packages
wrong newlines when downloading packages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.7
All Linux
low Severity low
: rc
: ---
Assigned To: John Matthews
Fanny Augustin
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-13 04:33 EDT by Jan Hutař
Modified: 2008-07-24 16:06 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0771
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 16:06:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2008-06-13 04:33:37 EDT
Description of problem:
When up2date is downloading packages, it was used to print nice progress bars. 
Now it prints only bunch of truncated package names.


Version-Release number of selected component (if applicable):
up2date-4.7.1-6.el4.x86_64


How reproducible:
always


Steps to Reproduce:
1. # up2date -u


Actual results:
Testing package set / solving RPM inter-dependencies...
########################################
bash-3.0-19.7.x86_64.rpm:    binutils-2.15.92.0.2-25.x86  coreutils-5.2.1-31.8.
el4.x8  cups-1.1.22-0.rc1.9.20.2.el  cups-libs-1.1.22-0.rc1.9.20  dhclient-3.0.
1-62.EL4.x86_6  e2fsprogs-1.35-12.17.el4.x8  ftp-0.17-23.el4_6.1.x86_64.  krb5-
libs-1.3.4-60.el4.x86_  krb5-workstation-1.3.4-60.e  libgcc-3.4.6-10.x86_64.rpm
:  libpcap-0.8.3-12.el4_6.1.x8  ...


Expected results:
Testing package set / solving RPM inter-dependencies...
########################################
bash-3.0-19.7.x86_64.rpm:   ########################## Done.                   
binutils-2.15.92.0.2-25.x86 ########################## Done.                   
coreutils-5.2.1-31.8.el4.x8 #####                      309 k/sec, 00:00:07 rem.


Additional info:
This is ssh in gnome-terminal if F9, window resized - but it worked correctly 
with up2date-4.6.2-7.el4_6.1.x86_64
Comment 1 RHEL Product and Program Management 2008-06-13 04:52:42 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 2 John Matthews 2008-06-16 11:18:30 EDT
Fixed, diff below.  


Index: up2dateRepo.py
===================================================================
--- up2dateRepo.py      (revision 173960)
+++ up2dateRepo.py      (working copy)
@@ -213,6 +213,7 @@
             f.seek(startpoint)
        #f.write(fd.read())
        shutil.copyfileobj(fd, f)  #bz434168: To avoid exceptions.OverflowError
when copying huge file
+        progressCallback(1,1)
         f.flush()
         f.close()
         fd.close()


Sending        repoBackends/up2dateRepo.py
Transmitting file data .
Committed revision 174032.


Comment 10 errata-xmlrpc 2008-07-24 16:06:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0771.html

Note You need to log in before you can comment on or make changes to this bug.