Bug 451220 - please upgrade perl module XML::LibXML to 1.66
please upgrade perl module XML::LibXML to 1.66
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: perl-XML-LibXML (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Marcela Mašláňová
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-13 09:57 EDT by Paul Bijnens
Modified: 2008-06-23 12:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-23 12:08:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Bijnens 2008-06-13 09:57:47 EDT
Several bugs in the perlmodule XML::LibXML 1.58-5 as packaged in RHEL 5.1 are
solved in the much more stable version 1.66.
Can the module be upgraded to XML::LibML 1.66 or later?

Version-Release number of selected component (if applicable):
perl-XML-LibXML-1.58-5

My most blocking bugs are about:

- impossible (or at least difficult without convoluted code) to 
  process tagnames that have a name "comment", "text", "document" (and others
  because they clash with the nodenames for xml-comments, textcontent, etc.
  Version 1.66 uses the DOM-compliant nodeNames like "#comment", "#text" 
  etc. for these.

- version v1.58 had inconsistent behaviour regarding bytes/characters 
  (utf8 flag on or off) from the toString method, making it very difficult 
  to avoid double utf8-encodings or "wide character" warnings.

- serious bug in cloneNode (loss of attributes).

- namespace support very buggy in v1.58.  This results in impossibility to 
  decently manipulate e.g. MS-Office 2007 OOXML files.

My workaround now is to install 1.66 using CPAN, breaking rpm/yum management,
or install in nonstandard places, and add "use lib ..." to every program.
Comment 1 Marcela Mašláňová 2008-06-23 11:56:15 EDT
We didn't planned upgrade of this package in RHEL-5.3. Also this package is
required by cman and I'm not sure if all those changes don't break something there.
Comment 2 Stepan Kasal 2008-06-23 12:08:29 EDT
The general policy of RHEL is not to accept new upstream versions, in order to
maintain backward compatibility of the API.
Though we see that the upgrade to 1.66 would be a benefit for you, it might
cause unexpected effects to other RHEL users.  Consequently, we decided not to
take the risk.

Note You need to log in before you can comment on or make changes to this bug.