Bug 451227 - krec hangs at startup
krec hangs at startup
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdemultimedia (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-13 10:27 EDT by Juha Tuomala
Modified: 2008-06-24 04:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-24 04:03:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juha Tuomala 2008-06-13 10:27:48 EDT
Description of problem:

I try to start krec and it hangs.

Version-Release number of selected component (if applicable):


How reproducible:

always

Actual results:
uname({sys="Linux", node="wasa", ...}) = 0
open("/dev/urandom", O_RDONLY)          = 14
read(14, "E[\335\33\253\342B\f\2105\270T\253\244\223k", 16) = 16
close(14)                               = 0
open("/tmp/ksocket-tuju/secret-cookie", O_WRONLY|O_CREAT|O_EXCL, 0600) = -1 
EEXIST (File exists)
open("/tmp/ksocket-tuju/secret-cookie", O_RDONLY) = 14
read(14, "cac0466788182608baf13ab50a4af024", 8192) = 32
close(14)                               = 0
ioctl(5, FIONREAD, [1])                 = 0
ioctl(5, FIONREAD, [1])                 = 0
open("/tmp/ksocket-tuju/Arts_SoundServerV2", O_RDONLY) = 14
read(14, "MCOP-Object:0000001d776173612e6e"..., 8192) = 206
close(14)                               = 0
socket(PF_FILE, SOCK_STREAM, 0)         = 14
setsockopt(14, SOL_SOCKET, SO_LINGER, {onoff=1, linger=100}, 8) = 0
connect(14, {sa_family=AF_FILE, path="/tmp/ksocket-tuju/wasa-0c4e-4833575e"}, 
110

and then nothing.
Comment 1 Rex Dieter 2008-06-13 10:40:47 EDT
Didn't you also report on irc that artscontrol hangs?  If so, you seem to have
bigger issues.
Comment 2 Juha Tuomala 2008-06-13 10:50:35 EDT
Yes, it seem to hang too.

That doesn't really change the fact that kde audio is broken on f8.

Should i file an own bug for artscontrol also?
Comment 3 Rex Dieter 2008-06-13 10:55:18 EDT
No, but I'm pretty sure what you're seeing is particular to your box, and that
these issues are related. :)
Comment 4 Juha Tuomala 2008-06-13 11:49:50 EDT
Want to make a bet? I install a fresh f8 and I quarantee that its audio is 
broken. :)

Only thing that i've done, is removed the pulseaudio-kde bridge pkg and 
wouldn't have done that if it wouldn't have been broken out-of-the-box.

Otherwise this box is intact.
Comment 5 Rex Dieter 2008-06-13 11:58:08 EDT
Sure, I've got ~150 boxes at my site that work just fine. :)
Comment 6 Rex Dieter 2008-06-13 11:58:46 EDT
oh, and you need to remove both
kde-settings-pulseaudio
and
alsa-plugins-pulseaudio
Comment 7 Juha Tuomala 2008-06-24 04:03:27 EDT
this was just screwed up system runtime situation. For some reason I'd 
lost some processes (ntp among them) and that killed sound too. 

thanks for your attention.

Note You need to log in before you can comment on or make changes to this bug.