Bug 45158 - anaconda SRPM needs several build dependencies listed
Summary: anaconda SRPM needs several build dependencies listed
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-20 16:46 UTC by Jay Turner
Modified: 2015-01-07 23:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-27 18:32:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Glen Foster 2001-06-20 16:46:22 UTC
Description of Problem: with the 7.1 product, you cannot build the anaconda
SRPM without having the following RPMs installed:
	newt-devel
	rpm-devel

But, if "rpm -ba /usr/src/redhat/SPECS/anaconda*spec" is executed, you do
NOT get an error from rpm about missing/unsatisfied build dependencies from
the above list of RPMs. If you install the above list of RPMs, the anaconda
SRPM builds with no errors.  Un-installing any of the above RPMs also
results in a build failure due to unstated-yet-present dependencies.

How Reproducible: Always

Steps to Reproduce:
    1. rpm -e <above-list-of-RPMs>
    2. rpm -Uvh <tree-path>/SRPMS/anaconda*.src.rpm
    3. rpm -ba /usr/src/redhat/SPECS/anaconda*spec
    4. rpm -Uvh <tree-path>/RedHat/RPMS/<above-list-of-RPMs> (and their
 associated dependencies)
    5. rpm -ba /usr/src/redhat/SPECS/anaconda*spec

Actual Results:
first 3 steps result in a failure WITHOUT a build-requires error from rpm
next 2 steps build the SRPM without fail

Expected Results:  I would expect an rpm error message to be written to
stderr informing me the anaconda SRPM cannot be built without installing
the above list of RPMs.

Comment 1 Michael Fulbright 2001-06-28 20:46:52 UTC
Fixed.


Note You need to log in before you can comment on or make changes to this bug.