Bug 451621 - No support to create PV on top of software raid device in kickstart
No support to create PV on top of software raid device in kickstart
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-16 04:46 EDT by Tomasz Kepczynski
Modified: 2008-11-04 11:32 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-04 11:32:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda crash dump (336.22 KB, text/plain)
2008-06-16 04:46 EDT, Tomasz Kepczynski
no flags Details

  None (edit)
Description Tomasz Kepczynski 2008-06-16 04:46:39 EDT
Description of problem:
In short: `raid' kickstart command allows creation of ext2,
ext3, swap, and vfat filesystems but it does not allow creation
of physical volume.
The longer story: I performed manual install on top of existing
VG located on PV which in turn was located on softraid device.
anaconda-ks.cfg created by installer had something along the lines:

#part raid.5 --noformat --onpart sda5
#part raid.12 --noformat --onpart sdb5
#part raid.13 --noformat --onpart sdb6
#part raid.6 --noformat --onpart sda6
#raid /boot --noformat --useexisting --fstype ext3 --level=RAID1 --device=md0
raid.5 raid.12
#raid pv.16 --noformat --useexisting --fstype "physical volume (LVM)"
--level=RAID1 --device=md1 raid.6 raid.13
#volgroup geralt --noformat --useexisting --pesize=4096 pv.16
#logvol / --fstype ext3 --name=F9 --vgname=geralt --size=10240
#logvol swap --fstype swap --name=SWAP.1 --vgname=geralt --size=4096

I tried to uncomment these lines and perform kickstart install
but that failed with very long traceback which I attach. I believe
this is due to --fstype option value in raid pv.16 line.
Comment 1 Tomasz Kepczynski 2008-06-16 04:46:39 EDT
Created attachment 309472 [details]
anaconda crash dump
Comment 2 Chris Lumens 2008-11-04 11:32:40 EST
This should be working in F10.

Note You need to log in before you can comment on or make changes to this bug.