Bug 451662 - Selecting paper type breaks ghostscript
Selecting paper type breaks ghostscript
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ghostscript (Show other bugs)
5.2
x86_64 Linux
high Severity high
: beta
: ---
Assigned To: Tim Waugh
QE Internationalization Bugs
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-16 11:20 EDT by Ralph Shepard
Modified: 2010-10-22 21:57 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:09:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ghostscript-setpagedevice.patch (667 bytes, patch)
2008-09-01 12:42 EDT, Tim Waugh
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0113 normal SHIPPED_LIVE ghostscript bug fix update 2009-01-20 11:04:44 EST

  None (edit)
Description Ralph Shepard 2008-06-16 11:20:30 EDT
ghostscript appears to be barfing when we specify the paper type.  Se below:
 
$ gs
ESP Ghostscript 815.02 (2006-04-19)
Copyright (C) 2004 artofcode LLC, Benicia, CA.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
GS>/media { /mt exch def << /DeferredMediaSelection true /MediaType mt
>> setpagedevice } def
GS>(Plain) media
ERROR: /configurationerror in --setpagedevice--
Additional information: [/DeferredMediaSelection true]
Operand stack:
    --dict:2/2(L)--
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--
--nostringval--   2   %stopped_push   --nostringval--
--nostringval--   %loop_continue   2   3   %oparray_pop
--nostringval--   --nostringval--   false   1   %
stopped_push   .runexec2   --nostringval--   --nostringval--
--nostringval--   2   %stopped_push   --nostringval--   1   3   %
oparray_pop   --nostringval--   --nostringval--   --nostringval--
--dict:1/2(L)--   --nostringval--   2   %dict_continue
Dictionary stack:
   --dict:1117/1686(ro)(G)--   --dict:0/20(G)--   --dict:104/200(L)--
Current allocation mode is local
Last OS error: 2
Current file position is 14
GS<1>==
-dict-
  
The same thing on the version that comes with RHEL3 ...
 
$ gs
GNU Ghostscript 7.05 (2002-04-22)
Copyright (C) 2002 artofcode LLC, Benicia, CA.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Loading NimbusRomNo9L-Regu font
from /usr/share/fonts/default/Type1/n021003l.pfb... 2430764 1062172
1642520 348080 0 done.
Loading NimbusSanL-Regu font
from /usr/share/fonts/default/Type1/n019003l.pfb... 2785628 1375364
1662616 359268 0 done.
GS>/media { /mt exch def << /DeferredMediaSelection true /MediaType mt
>> setpagedevice } def
GS>(Plain) media
GS>
  
On the version of gs used by Ubuntu 7.10 it works also ...
  
$ gs
GPL Ghostscript SVN PRE-RELEASE 8.61 (2007-08-02)
Copyright (C) 2007 Artifex Software, Inc.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
GS>/media { /mt exch def << /DeferredMediaSelection true /MediaType mt
>> setpagedevice } def
GS>(Plain) media
GS>
  
As far as I can see, this is a regression in RHEL5.  Without this
functionality we are unable to select paper type (e.g. letterhead)
when printing a document.
Comment 1 Tim Waugh 2008-06-17 05:30:27 EDT
Confirmed.
Comment 4 RHEL Product and Program Management 2008-07-25 05:26:00 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 5 Steve Baldwin 2008-08-13 19:22:47 EDT
So, how is progress on this bug?  We are planning on starting migrating our projects to RHEL5 in 2 weeks but this bug will break our existing apps.

It has been 2 months since this bug was reported and there is no sign of any progress.  Sure we can package our own ghostscript from the latest source, but isn't this what we pay our RHEL subscription for?
Comment 8 Tim Waugh 2008-09-01 12:42:10 EDT
Created attachment 315489 [details]
ghostscript-setpagedevice.patch

Proposed patch attached.

This brings the ESP changes to gs_setpd.ps in line with the code that was merged into the upstream GPL branch.
Comment 11 RHEL Product and Program Management 2008-09-02 20:05:02 EDT
This bugzilla was reviewed by QE as a non-FasTrack request.
It has since been proposed for FasTrack. The qa_ack has 
been reset. QE needs to re-review this bugzilla for FasTrack.
Comment 22 errata-xmlrpc 2009-01-20 16:09:47 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0113.html

Note You need to log in before you can comment on or make changes to this bug.