Bug 45168 - Get fatal errors when upgrading from 6.1 to 7.1
Get fatal errors when upgrading from 6.1 to 7.1
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-20 15:21 EDT by sparks
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 09:53:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sparks 2001-06-20 15:21:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.61 [en] (Win98; U)

Description of problem:
install with lowres switch, gets past the query of the kind of install I'd like, then crashes

How reproducible:
Always

Steps to Reproduce:
1.start 'er up with "lowres" at boot prompt
2.go through the motions
3.watch the fireworks
	

Actual Results:  Error dialog box with option to save to floppy.

Expected Results:  smooth install

Additional info:

THIS IS THE ERROR MESSAGE I WAS ABLE TO CAPTURE ON FLOPPY:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 520, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/gui.py", line 391, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/gui.py", line 879, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/gui.py", line 481, in nextClicked
    next = self.currentScreen.getNext ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/examine_gui.py", line 19, in getNext
    self.todo.upgradeMountFilesystems (self.root)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1187, in upgradeMountFilesystems
    allowDirty = 0)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/upgrade.py", line 88, in mountRootPartition
    fstab.readFstab(instPath + '/etc/fstab', theFstab)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/fstab.py", line 1196, in readFstab
    fields[2], raidByDev[int(fields[0][7:])])
KeyError: 0

Local variables in innermost frame:
loopIndex: {}
fstab: <fstab.GuiFstab instance at 8481eb0>
labelsByMount: {}
line: /dev/md0                /home                   ext2    defaults        1 2

path: /mnt/sysimage/etc/fstab
device: hda1
raidByDev: {}
fsystem: ext2
drives: ['hda']
lines: ['/dev/hda6               /                       ext2    defaults        1 1\012', '/dev/hda1               /boot                   ext2    defaults     
   1 2\012', '/dev/md0                /home                   ext2    defaults        1 2\012', '/dev/cdrom              /mnt/cdrom              iso9660 
noauto,owner,ro 0 0\012', '/dev/hda5               swap                    swap    defaults        0 0\012', '/dev/fd0                /mnt/floppy      
       ext2    noauto,owner    0 0\012', 'none                    /proc                   proc    defaults        0 0\012', 'none                    
/dev/pts                devpts  gid=5,mode=620  0 0\012']
labels: {}
fields: ['/dev/md0', '/home', 'ext2', 'defaults', '1', '2']
f: <open file '/mnt/sysimage/etc/fstab', mode 'r' at 84acad0>
raidList: []

ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'
p3
S''
sS'progressWindow'
p4
NsS'setupFilesystems'
p5
I1
sS'monitorVsync'
p6
S''
sS'videoCardStateNode'
p7
S''
sS'serial'
p8
I0
sS'ddruidReadOnly'
p9
I0
sS'bootdisk'
p10
I0
sS'videoRamState'
p11
S''
sS'monitorOriginalName'
p12
S''
sS'language'
p13
(itodo
Language
(dp14
S'langInfoByName'
p15
(dp16
S'Arabic (Yemen)'
p17
(S'ar_YE'
S'iso06'
S'LatArCyrHeb-16'
tsS'Spanish (Argentina)'
p18
(S'es_AR'
S'iso01'
S'lat0-sun16'
tsS'Italian (Italy)'
p19
(S'it_IT@euro'
S'iso15'
S'lat0-sun16'
tsS'Arabic (Lebanon)'
p20
(S'ar_LB'
S'iso06'
S'LatArCyrHeb-16'
tsS'Spanish (Guatemala)'
p21
(S'es_GT'
S'iso01'
S'lat0-sun16'
tsS'Malay (Malaysia)'
p22
(S'ms_MY'
S'iso01'
S'lat0-sun16'
tsS'Arabic (Libyan Arab Jamahiriya)'
p23
(S'ar_LY'
S'iso06'
S'LatArCyrHeb-16'
tsS'Arabic (Oman)'
p24
(S'ar_OM'
S'iso06'
S'LatArCyrHeb-16'
tsS'Arabic (Iraq)'
p25
(S'ar_IQ'
S'iso06'
S'LatArCyrHeb-16'
tsS'Arabic (Kuwait)'
p26
(S'ar_KW'
S'iso06'
S'LatArCyrHeb-16'
tsS'English (South Africa)'
p27
(S'en_ZA'
S'iso01'
S'lat0-sun16'
tsS'French (Switzerland)'
p28
(S'fr_CH'
S'iso01'
S'lat0-sun16'
tsS'Arabic (Bahrein)'
p29
(S'ar_BH'
S'iso06'
S'LatArCyrHeb-16'
tsS'Croatian'
p30
(S'hr_HR'
S'iso02'
S'lat2-sun16'
tsS'French (France)'
p31
(S'fr_FR@euro'
S'iso15'
S'lat0-sun16'
tsS'Greenlandic (Greenland)'
p32
(S'kl_GL'
S'iso01'
S'lat0-sun16'
tsS'Korean (Republic of Korea)'
p33
(S'ko_KR.euckr'
S'iso01'
S'lat0-16'
tsS'Ukrainian'
p34
(S'uk_UA'
S'koi8-u'
S'cyr-sun16'
tsS'Spanish (Mexico)'
p35
(S'es_MX'
S'iso01'
S'lat0-sun16'
tsS'Greek'
p36
(S'el_GR'
S'iso07'
S'gr.f16'
tsS'Spanish (El Salvador)'
p37
(S'es_SV'
S'iso01'
S'lat0-sun16'
tsS'Spanish (Peru)'
p38
(S'es_PE'
S'iso01'
S'lat0-sun16'
tsS'Spanish (Honduras)'
p39
(S'es_HN'
S'iso01'
S'lat0-sun16'
tsS'Spanish (Costa Rica)'
p40
(S'es_CR'
S'iso01'
S'lat0-sun16'
tsS'English (Denmark)'
p41
(S'en_                                                                                                                                                                                   
                                                                                                                                                                                            
 [MANY SPACES BETWEEN THESE TWO TEXT BLOCKS -TOM SPARKS]                                                                                  
                                                                                                                                                                                            
                                                                                                                                                                          08
(S'sl_SI'
S'iso02'
S'lat2-sun16'
tsS'Spanish (Uruguay)'
p109
(S'es_UY'
S'iso01'
S'lat0-sun16'
tsS'German (Switzerland)'
p110
(S'de_CH'
S'iso01'
S'lat0-sun16'
tsS'English (Hong Kong)'
p111
(S'en_HK'
S'iso01'
S'lat0-sun16'
tsS'English (Australia)'
p112
(S'en_AU'
S'iso01'
S'lat0-sun16'
tsS'Catalan (Spain)'
p113
(S'ca_ES@euro'
S'iso15'
S'lat0-sun16'
tsS'Spanish (Puerto Rico)'
p114
(S'es_PR'
S'iso01'
S'lat0-sun16'
tsS'Turkish'
p115
(S'tr_TR'
S'iso09'
S'lat5-sun16'
tsS'Estonian'
p116
(S'et_EE'
S'iso01'
S'lat0-sun16'
tsS'Arabic (Sudan)'
p117
(S'ar_SD'
S'iso06'
S'LatArCyrHeb-16'
tsS'Icelandic'
p118
(S'is_IS'
S'iso01'
S'lat0-sun16'
tsS'English (Botswana)'
p119
(S'en_BW'
S'iso01'
S'lat0-sun16'
tsS'Manx Gaelic (Britain)'
p120
(S'gv_GB'
S'iso01'
S'lat0-sun16'
tssS'allSupportedLangs'
p121
(lp122
g46
ag79
ag50
ag29
ag95
ag25
ag76
ag26
ag20
ag23
ag48
ag24
ag94
ag103
ag117
ag73
ag99
ag59
ag17
ag93
ag113
ag53
ag58
ag30
ag74
ag52
ag83
ag42
ag112
ag119
ag106
ag41
ag86
ag111
ag97
ag56
ag49
ag82
ag27
ag64
ag89
ag116
ag54
ag80
ag96
ag105
ag31
ag100
ag28
ag55
ag60
ag78
ag107
ag91
ag110
ag36
ag32
ag63
ag98
ag118
ag51
ag75
ag19
ag77
ag101
ag33
ag70
ag22
ag120
ag47
ag88
ag68
ag66
ag45
ag61
ag87
ag44
ag43
ag69
ag108
ag18
ag57
ag72
ag92
ag40
ag104
ag37
ag67
ag21
ag39
ag35
ag90
ag84
ag62
ag38
ag114
ag71
ag65
ag109
ag85
ag102
ag81
ag115
ag34
asS'info'
p123
(dp124
S'SUPPORTED'
p125
NssS'supported'
p126
(lsS'default'
p127
NsbsS'instClass'
p128
(iinstallclass
DefaultInstall
p129
(dp130
S'rootPasswordCrypted'
p131
I0
sS'raidList'
p132
(lsS'nameserver'
p133
S''
sS'x'
NsS'rootPassword'
p134
NsS'makeBootdisk'
p135
I0
sS'installType'
p136
NsS'postScript'
p137
NsS'earlySwapOn'
p138
I0
sS'networkDevice'
p139
NsS'fstab'
p140
(lsS'clearText'
p141
NsS'lilo'
p142
(S'mbr'
p143
I1
S''
tsg13
NsS'name'
p144
S''
sS'postInChroot'
p145
I0
sS'pixmap'
p146
S''
sS'partitions'
p147
(lsS'clearType'
p148
NsS'gateway'
p149
S''
sS'mouse'
p150
NsS'packages'
p151
NsS'timezone'
p152
NsS'zeroMbr'
p153
I0
sS'keyboard'
p154
NsS'groups'
p155
NsS'bootProto'
p156
NsS'netmask'
Comment 1 Brent Fox 2001-06-21 15:34:45 EDT
Can you attach your /etc/fstab file?
Comment 2 sparks 2001-06-22 10:11:50 EDT
/dev/hda6               /                       ext2    defaults        1 1
/dev/hda1               /boot                   ext2    defaults        1 2
/dev/md0                /home                   ext2    defaults        1 2
/dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,ro 0 0
/dev/hda5               swap                    swap    defaults        0 0
/dev/fd0                /mnt/floppy             ext2    noauto,owner    0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/pts                devpts  gid=5,mode=620  0 0

The above /etc/fstab file is from my current RH6.1 installation.

I should say, to get my machine to boot to the point where the upgrade failed, I had to disconnect the two drives that make up the /dev/md0.

These drives are two 20GB Quantum Fireball Plus LMs connected to a Highpoint366 ATA/66 controller that RH7.1 seems to have trouble 
probing.  (SEE BUG 45154)
Comment 3 sparks 2001-07-19 15:20:33 EDT
Tried install again and used the following kernel directive after reattaching the drives to the secondary controller:

ide2=0xcc00,0xd002,18 ide3=0xd800,0xdc02,18

and it worked.  Not sure why this would make a difference, but it did.
I got these numbers from the Gentus Linux "dmesg" boot log.

Total time of upgrade took about 10 hours.  It seemed to hang for extended periods at various times.

Not impressed with RedHat 7.1's stability. At boot time, it will randomly hang upon starting various services like sendmail or apache. 
I often have to start these services manually as starting these things at boot time fail.  Often have to boot several times to acheive a successful boot.

Gentus Linux was rock stable on this Abit BP6.  RedHat Linux 7.1 doesn't seem stable at all.  It is frighteningly unpredictable on this machine.

I'm sorry now that I upgraded.
Comment 4 Matt Wilson 2001-07-19 15:26:11 EDT
kernel bug.
Comment 5 Arjan van de Ven 2001-07-19 15:29:01 EDT
Do you have IDE disks connected to the HPT controller on the BP6? 
Could you try booting with either "ide=nodma" or "noapic" on the lilo kernel
commandline ?
Comment 6 sparks 2001-07-20 13:41:08 EDT
My earlier doubts about RedHat 7.1's stability may have been misplaced.  RH7.1 DOES seem stable.  I noticed that if I booted the machine 
cold, (8 or 9 hours since running it last) that it booted normally, even swiftly.  But rebooting hot yielded unpredictable results.

I suspected a heat problem.  I cleaned the case's inlet air filter, cleaned all fan grills (there are two130mm fans and one 92mm fan just in
the enclosure in addition to the four fans on the processors, and the fan in the power supply.)  Cleaned the BX chip's heat sink. Removed the 
processors and heat sinks to look for accumulations of dust.  Sure enough, there was significant dust on the heat sinks. 
Vacuumed them off and ran the machine. Booted fine, rebooted hot, booted fine.

RedHat 7.1 seems every bit as stable as Gentus Linux. I apologize for even thinking there was a stability problem with RH7.1.
As a further precaution, I redirected air-conditioned air from other areas to the host's area.

There are two drives connected to the HPT366: a pair of Quantum Fireball Plus LM's of 20GB size, arranged in a RAID0 array and 
mounted at /home.

No need to try the ide=nodma or noapic stuff.  All seems well.

I suspect the problems with Anaconda were probably also due to the heat problem.

One question remains:  Why would heat suddenly be an issue with RH7.1?  Is the 2.4 kernel more sensitive to timing issues than 2.2?

I'll keep looking at this machine over the next few weeks and I'll let you know how things go.
Comment 7 Arjan van de Ven 2001-07-20 13:46:21 EDT
"Is the 2.4 kernel more sensitive to timing issues than 2.2?"

For one, 2.4 using DMA on IDE disks, which means the chipset is getting used
harder  (the speed is much higher, so the chipset has to do more work)....

Several other areas have performance-improvements, which therefore mean the
hardware is loaded higher.


Comment 8 sparks 2001-08-03 09:30:35 EDT
It appears I was premature in saying the problem was ONLY heat related.  It does have some relationship to heat, but heat is only an 
aggravating factor.  There seem to be other stability problems.

Booting cold, (Really cold, computer in A/C'd room overnight, chipset, and CPU's cool to the touch.) will hang the system on the geometry query
of the boot process.  Repeated booting can get it past this point although not predictably.

Rebooting hot can cause the boot process to hang as above but will also hang on starting sendmail.

Once it is up and running it usually works OK, but I have had to reboot to shake off some flakiness.

Note You need to log in before you can comment on or make changes to this bug.