Bug 45170 - Signal 9 Failure during Package Installation
Summary: Signal 9 Failure during Package Installation
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-20 19:35 UTC by Need Real Name
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-21 20:36:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.txt dump (1.12 KB, text/plain)
2001-06-20 19:36 UTC, Need Real Name
no flags Details

Description Need Real Name 2001-06-20 19:35:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
Gets 98% of way thru package installation, fails with signal 9 
(anaconda.txt dump produced). Environment: Text mode install, Buslogic BT-
946C scsi controller, installing to second disk. No IDE drives; scsi card 
has 2 HDs and a plextor CDROM. CPU P166, RAM 59 MB. Video ATI Mach64 (have 
to use text mode). Installing on 2nd disk (ID=1), 2.1 GB, dedicated 
(nothing else on the drive). Used DD to partition disk: 16 MB boot, 256 MB 
swap, rest is root.  Tried various install modes: custom, server, etc., 
with minimal package selections. Same result. No info in VC's. 

How reproducible:
Always

Steps to Reproduce:
1. Boot from diskette (boot.img)
2. Partition SCSI drive (sdb1, sdb5, sdb6) using Disk Druid
3. custom install, select hardware & packages
4. begin install
	

Actual Results:  Progress bar almost complete, get internal error. Crashes 
with signal 9.

Expected Results:  Installation completes, writes image, etc.

Additional info:

May be related to Bug # 39604. Note: both entail machines with
less than 64 MB, and the comments there point to a patch for this
case.

Comment 1 Need Real Name 2001-06-20 19:36:34 UTC
Created attachment 21405 [details]
anaconda.txt dump

Comment 2 Brent Fox 2001-06-21 19:24:02 UTC
Did you set mount points for any DOS partitions during the install? 

Also, did you go on VC2 and enter the /mnt/source directory?

Comment 3 Need Real Name 2001-06-21 20:36:42 UTC
6/21/01 No, I didn't set any Dos mount points. But I later ran a totally 
minimal install -- no packages -- and it was successful. At one point the 
package installer choked while loading some clib libraries. After three tries, 
it succeeded in installing the file. I checked the VC3 log, and it identified 
an error on SCSI 0 (the only SCSI controller), ID #6, which is the CDROM unit. 
It appears from all the information that the install program is encountering 
occasional IO errors on the CDROM unit -- an old Plextor 6X. I suspect this 
unit may be flaky and may be causing intermittent problems. 
   Also noticed a message in one of the VCs that it "saw" 64MB. Interesting, 
because there are only 60 MB RAM on the machine. Didn't seems to cause a 
problem, though. 
   Anyway, I'll close this bug on the belief that IO errors on the CDROM unit 
are the cause.

Comment 4 Brent Fox 2001-06-22 00:05:51 UTC
Do you see anything on VC4 that has anything to do with DMA errors, or CDROM
Seek errors?

Comment 5 Need Real Name 2001-06-22 16:32:33 UTC
6/22/01: I don't recall seeing anything about these on VC4, but I'll look for 
them when I run the rebuild.


Note You need to log in before you can comment on or make changes to this bug.