Bug 452073 - service "RPC svcgssd" failed, httpd is started when stopping HTS server
service "RPC svcgssd" failed, httpd is started when stopping HTS server
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5
i386 Linux
low Severity low
: ---
: ---
Assigned To: Greg Nichols
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-19 03:03 EDT by Yolkfull Chow
Modified: 2014-03-25 20:55 EDT (History)
6 users (show)

See Also:
Fixed In Version: hts-5.2-20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 12:46:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yolkfull Chow 2008-06-19 03:03:01 EDT
Description of problem:
When issue "hts server stop" after have starting hts server, service RPC svcgssd
will fail.

Version-Release number of selected component (if applicable):
HTS 5.2 R16

How reproducible:
Everytime

Steps to Reproduce:
1. issue "hts server start"
2. issue "hts server stop"
  
Actual results:
"RPC svcgssd" failed

Expected results:
hts server could be started and stopped successfully

Additional info:
#hts server stop
OS Version: Red Hat Enterprise Linux AS release 4 (Nahant Update 7 Beta)
Kernel RPM: kernel-smp-2.6.9-71.EL
HTS version 5.2, release 16
Note: decimal module from python 2.5 copied by HTS
make server RUNMODE=stop
python network.py server stop
Stopping lmbench services... done.
Shutting down RPC svcgssd:                                 [FAILED]
Shutting down NFS mountd:                                  [  OK  ]
Shutting down NFS daemon:                                  [  OK  ]
Shutting down NFS quotas:                                  [  OK  ]
Shutting down NFS services:                                [  OK  ]
Starting httpd:

Since this problem is not happen against any component in the list which we must
choose within, I would choose network for it,anyone who don't think it's
suitable and would change will be appreciated.
Comment 1 lihuang 2008-06-19 04:39:38 EDT
service Httpd is not be stopped when shutting down hts server.


#hts server stop
OS Version: Red Hat Enterprise Linux Server release 5.2 (Tikanga)
Kernel RPM: kernel-2.6.18-92.el5
HTS version 5.2, release 16
make server RUNMODE=stop
python network.py server stop
Stopping lmbench services... done.
Shutting down NFS mountd:                                  [  OK  ]
Shutting down NFS daemon:                                  [  OK  ]
Shutting down NFS services:                                [  OK  ]
Starting httpd: 
[root@jupiter ~]# ps -aef | grep httpd
root     30717     1  0 00:31 pts/2    00:00:00 /usr/sbin/nss_pcache off
/etc/httpd/alias
root     30719     1  0 00:31 ?        00:00:00 /usr/sbin/httpd
apache   30724 30719  0 00:31 ?        00:00:00 /usr/sbin/httpd
apache   30725 30719  0 00:31 ?        00:00:00 /usr/sbin/httpd
apache   30726 30719  0 00:31 ?        00:00:00 /usr/sbin/httpd
apache   30727 30719  0 00:31 ?        00:00:00 /usr/sbin/httpd
apache   30728 30719  0 00:31 ?        00:00:00 /usr/sbin/httpd
apache   30729 30719  0 00:31 ?        00:00:00 /usr/sbin/httpd
apache   30730 30719  0 00:31 ?        00:00:00 /usr/sbin/httpd
apache   30731 30719  0 00:31 ?        00:00:00 /usr/sbin/httpd
root     30791  9971  0 00:32 pts/2    00:00:00 grep httpd
[root@jupiter ~]# 
Comment 2 Greg Nichols 2008-06-19 09:01:14 EDT
The RPC svcgssd issue may be due to running the server on RHEL 4.  This does not
appear to happen if the server is run on a RHEL 5 system.

Changing bug summary to mention the httpd issue.
Comment 3 Yolkfull Chow 2008-06-20 01:04:31 EDT
Greg:
Yeh,this problem will not happen on RHEL 5 system. I did some debugging and this
problem seemingly due to the daemon rpc.svcgssd itself.

#hts server start
OS Version: Red Hat Enterprise Linux AS release 4 (Nahant Update 7 Beta)
Kernel RPM: kernel-2.6.9-71.EL
HTS version 5.2, release 16
Note: decimal module from python 2.5 copied by HTS
make server RUNMODE=start
python network.py server start
Starting lmbench services... done.
Starting NFS services:                                     [  OK  ]
Starting NFS quotas:                                       [  OK  ]
Starting NFS daemon:                                       [  OK  ]
Starting NFS mountd:                                       [  OK  ]
Starting httpd:

[root@dhcp-65-93 /]# hts server status
OS Version: Red Hat Enterprise Linux AS release 4 (Nahant Update 7 Beta)
Kernel RPM: kernel-2.6.9-71.EL
HTS version 5.2, release 16
Note: decimal module from python 2.5 copied by HTS
make server RUNMODE=status
python network.py server status
lmbench bw_tcp is running
lmbench lat_udp is running
/var/hts/export is exported
rpc.svcgssd is stopped      --------------> rpc.svcgssd is not running
rpc.mountd (pid 25941) is running...
nfsd (pid 25935 25934 25933 25932 25931 25930 25929 25928) is running...
rpc.rquotad (pid 25924) is running...
httpd (pid 25133 25132 25131 25130 25129 25128 25127 25126 25123) is running...

[root@dhcp-65-93 /]# rpc.svcgssd -f
ERROR: GSS-API: error in gss_acquire_cred(): Miscellaneous failure - No such
file or directory
unable to obtain root (machine) credentials
do you have a keytab entry for nfs/<your.host>@<YOUR.REALM> in /etc/krb5.keytab?
Comment 4 Greg Nichols 2008-08-21 21:40:08 EDT
Fixed in HTS 5.2 R19
Comment 5 Greg Nichols 2008-08-27 21:43:58 EDT
Delayed to HTS 5.3
Comment 8 Nicole Dai 2008-10-10 06:20:23 EDT
Confirmed the bug has not been fixed in hts-5.2-20.el4.
Comment 9 Greg Nichols 2008-10-10 12:42:20 EDT
How was this confirmed?  Per cvs, the fix is in R20.
Comment 10 Nicole Dai 2008-10-12 22:56:08 EDT
# hts server stop
OS Version: Red Hat Enterprise Linux AS release 4 (Nahant Update 7)
Kernel RPM: kernel-smp-2.6.9-78.EL
HTS version 5.2, release 20
Note: decimal module from python 2.5 copied by HTS
make server RUNMODE=stop
python network.py server stop
Stopping lmbench services... done.
Shutting down RPC svcgssd:                                 [FAILED]
Shutting down NFS mountd:                                  [  OK  ]
Shutting down NFS daemon:                                  [  OK  ]
Shutting down NFS quotas:                                  [  OK  ]
Shutting down NFS services:                                [  OK  ]
Stopping httpd:                                            [  OK  ]
# rpm -q hts
hts-5.2-20.el4
# ps -aef | grep httpd
root     25222 24930  0 02:46 pts/2    00:00:00 grep httpd

The problem described in Comment #1 has been fixed but the original bug has not been fixed yet.
Comment 11 Rob Landry 2008-12-09 12:46:43 EST
The "original bug" is not an hts problem but a RHEL issue; specifically BZ #470423.  This issue as the modified bug should be closed as it's already confirmed fixed, we can open a new bug later if the RHEL update does not resolve.

Note You need to log in before you can comment on or make changes to this bug.