Bug 45208 - Broadcom nic driver (bcm5700) unable to initialize in Seawolf IA64 gold
Broadcom nic driver (bcm5700) unable to initialize in Seawolf IA64 gold
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
ia64 Linux
low Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-20 16:36 EDT by Matt Domsch
Modified: 2007-03-26 23:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-20 16:57:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2001-06-20 16:36:56 EDT
Description of Problem:
On a Dell PowerEdge 7150 w/ A01 bios, and 25GB RAM running Seawolf IA-64 
gold.  Kudzu detects broadcom nic and adds "alias" line to modules.conf.  
After setting ethernet interface to bcm5700 in netconf, I attempt to bring 
interface up.   Console states "failed initialization."   Checked physical 
network connection and that's good.  After each unsuccessful attempt to 
load bcm5700 module, I check module resource usage w/ lsmod and see that 3 
additional resources are using the module after every insmod.  So I can't 
unload the module.  I reboot, and attempt to load the module while passing 
the line_speed=100 parameter.  This causes a kernel panic. 


How Reproducible:
Always

Steps to Reproduce:
1. modprobe bcm5700
2. 
3. 

Actual Results:
Driver doesn't pass data

Expected Results:
Driver passes data

Additional Information:
This driver is a "nice to have", but Broadcom didn't have any IA-64 
hardware to develop and test on, so it's not too suprising that it doesn't 
work.  Broadcom will have this fixed by 7/9/01 for the Fairfax release, by 
releasing a different driver that supports new cards on both IA-32 and IA-
64.
Comment 1 Arjan van de Ven 2001-06-20 16:42:52 EDT
The way it's looking, people are rewriting the broadcom driver to actually look
like a linux driver and include it in the main kernel. I hope broadcom will
see the light and work with them so that a good driver will result.
Judging from the current code, a LOT of work is needed to clean it up, rewriting
might be simpler.
Comment 2 Bill Nottingham 2001-06-20 16:57:01 EDT
Odd. It worked the one time I tried it.

I'm guessing it's not using the new PCI DMA api.
Comment 3 Matt Domsch 2001-07-11 13:27:17 EDT
Broadcom submitted a new driver for Fairfax which Arjan says is included in the 
beta2 kernel.  I'll close this issue out.

Note You need to log in before you can comment on or make changes to this bug.