Bug 45209 - licq SRPM needs several build dependencies liste
licq SRPM needs several build dependencies liste
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: licq (Show other bugs)
7.3
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-20 16:47 EDT by Jay Turner
Modified: 2015-01-07 18:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-21 09:28:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Glen Foster 2001-06-20 16:47:37 EDT
Description of Problem: with the 7.1 product, you cannot build the licq
SRPM without having the following RPMs installed:
	XFree86-devel
	ncurses-devel

But, if "rpm -ba /usr/src/redhat/SPECS/licq*spec" is executed, you do NOT
get an error from rpm about missing/unsatisfied build dependencies from the
above list of RPMs. If you install the above list of RPMs, the licq SRPM
builds with no errors.  Un-installing any of the above RPMs also results in
a build failure due to unstated-yet-present dependencies.

How Reproducible: Always

Steps to Reproduce:
    1. rpm -e <above-list-of-RPMs>
    2. rpm -Uvh <tree-path>/SRPMS/licq*.src.rpm
    3. rpm -ba /usr/src/redhat/SPECS/licq*spec
    4. rpm -Uvh <tree-path>/RedHat/RPMS/<above-list-of-RPMs> (and their
 associated dependencies)
    5. rpm -ba /usr/src/redhat/SPECS/licq*spec

Actual Results:
first 3 steps result in a failure WITHOUT a build-requires error from rpm
next 2 steps build the SRPM without fail

Expected Results:  I would expect an rpm error message to be written to
stderr informing me the licq SRPM cannot be built without installing the
above list of RPMs.
Comment 1 Bernhard Rosenkraenzer 2001-06-25 10:52:41 EDT
Fixed in 1.0.3-4

Note You need to log in before you can comment on or make changes to this bug.