Bug 452115 - New installation of Miro does not display the channel guide.
New installation of Miro does not display the channel guide.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Miro (Show other bugs)
9
i686 Linux
low Severity high
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
:
: 452182 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-19 10:29 EDT by Jason Fenner
Modified: 2008-06-20 15:13 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.2.4-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-20 15:13:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Fenner 2008-06-19 10:29:21 EDT
Description of problem:
New installation of Miro does not display the channel guide.

Version-Release number of selected component (if applicable):
Miro-1.2.3-2.fc9.i386


How reproducible:
Always reproducible.


Steps to Reproduce:
1.  Install Miro.  Example:  yum install Miro
2.  Start Miro.  Example in Gnome: Applicatoins -> Sound & Video -> Miro
3.  Once Miro opens, notice no channel guides are displayed and search results
are also not displayed.

  
Actual results:
Miro runs, however the 'channel guide box' is blank.  The channel guide is not
visible.


Expected results:
It is expected that once Miro starts and opens, that the channel guide will be
displayed.


Additional info:
This same behaviour has been confirmed on x86_64.

Here is the output from miro_log upon starting and stopping Miro:

2008-06-19 10:26:54,815 INFO     Starting up Miro
2008-06-19 10:26:54,816 INFO     Version:    1.2.3
2008-06-19 10:26:54,816 INFO     Revision:  
https://svn.participatoryculture.org/svn/dtv/tags/Miro-1.2.3/tv/resources - 6787
2008-06-19 10:26:54,816 INFO     Builder:   
mockbuild@xenbuilder4.fedora.phx.redhat.com
2008-06-19 10:26:54,817 INFO     Build Time: 1209387954.81
2008-06-19 10:26:54,817 INFO     Starting event loop thread
2008-06-19 10:26:54,837 INFO     Restoring database...
2008-06-19 10:26:54,838 INFO     Connecting to /home/jfenner/.miro/sqlitedb
2008-06-19 10:26:55,345 TIMING   Database load slow: 0.507
2008-06-19 10:26:55,585 TIMING   idle (finish startup) too slow (0.763 secs)
2008-06-19 10:26:55,609 INFO     Spawning auto downloader...
2008-06-19 10:26:55,706 TIMING   Icon clear: 0.011
2008-06-19 10:26:55,707 INFO     Starting movie data updates
2008-06-19 10:26:55,709 INFO     Displaying main frame...
2008-06-19 10:26:55,929 WARNING  Menu item action "RenameVideo" not implemented
2008-06-19 10:26:55,929 INFO     Creating video display...
2008-06-19 10:26:55,930 WARNING  Menu item action "FastForward" not implemented
2008-06-19 10:26:55,930 WARNING  Menu item action "Rewind" not implemented
2008-06-19 10:26:55,930 WARNING  Menu item action "UpVolume" not implemented
2008-06-19 10:26:55,930 WARNING  Menu item action "DownVolume" not implemented
2008-06-19 10:26:55,942 DEBUG    Setting VolumeLevel to 1.0
2008-06-19 10:26:55,942 DEBUG    Processing tablist
2008-06-19 10:26:55,959 DEBUG    Setting VolumeLevel to 1.0
2008-06-19 10:26:55,977 INFO     Finished startup sequence
2008-06-19 10:26:56,102 INFO     loaded renderer 'gstreamerrenderer'
2008-06-19 10:26:56,143 WARNING  Error setting up drag and drop dummy element
2008-06-19 10:26:56,155 DEBUG    Processing guide-loading
2008-06-19 10:26:56,156 INFO     First URL is https://www.miroguide.com/
2008-06-19 10:26:58,937 INFO     Checking for updates...
2008-06-19 10:26:59,215 INFO     Shutting down Downloader...
2008-06-19 10:26:59,447 INFO     Closing Database...
2008-06-19 10:26:59,793 INFO     Shutting down event loop
2008-06-19 10:27:01,426 INFO     Shutting down frontend
2008-06-19 10:27:01,427 TIMING   WARNING: Running:
<miro.dl_daemon.command.ShutDownResponseCommand instance at 0x9353f6c> too slow
(1.980 secs)
2008-06-19 10:27:01,427 INFO     Saving preferences...
2008-06-19 10:27:01,427 INFO     Shutting down icon cache updates
2008-06-19 10:27:01,428 INFO     Shutting down movie data updates
2008-06-19 10:27:01,428 INFO     Done shutting down.
2008-06-19 10:27:01,428 INFO     Remaining threads are:
2008-06-19 10:27:01,429 INFO     <_MainThread(MainThread, started)>
 
Here is the output from
Comment 1 Alex Lancaster 2008-06-19 12:38:39 EDT
This was caused by the bump to xulrunner-1.9 final.  An update rebuilt against
the new xulrunner is already pending for F-9, feel free to test:

https://admin.fedoraproject.org/updates/F9/pending/Miro-1.2.4-1.fc9
Comment 2 Jason Fenner 2008-06-19 12:52:04 EDT
I tested the pending update and it works great.  Also updated Bodhi with my test
result.
Comment 3 Alex Lancaster 2008-06-20 00:35:08 EDT
*** Bug 452182 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2008-06-20 15:13:47 EDT
Miro-1.2.4-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.