Bug 45212 - safedelchk doesn't actually delete the safedeleted files
safedelchk doesn't actually delete the safedeleted files
Status: CLOSED CURRENTRELEASE
Product: Red Hat Powertools
Classification: Retired
Component: safedelete (Show other bugs)
7.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: bero
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-20 17:41 EDT by Jeffrey Wacaser
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-17 10:24:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey Wacaser 2001-06-20 17:41:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.19-7.0.1 i686; en-US; rv:0.9.1)
Gecko/20010607

Description of problem:
I believe the safedelchk program is getting confused on the date.  I can
safedelete and undelete files fine.  When I run the safedelchk program to
purge old files, it puts says deleting files older than 6/20/ without
giving the year.  It then states that 0 files were purged even though I
have files older than my $SAFEDAYS defined variabled which I have tried
changing.

How reproducible:
Always

Steps to Reproduce:
1../safedelchk
2.
3.
	

Actual Results:  sjwacaser@mosh> safedelchk
safedelchk: scan beginning
safedelchk: removing files safedeleted before 06/20/
safedelchk: 0 file(s) removed
safedelchk: scan completed
jwacaser@mosh> 
jwacaser@mosh> undelete -i | more

/home/jwacaser/Employee%20Communication%20-%20Option%20Program%20Intro.doc
	Date deleted: 06/19/01
	Permissions: -rw-r--r--
	Owners login name: jwacaser
	Owners group name: jwacaser
	Size: 55296
	Last accessed: 06/19/01
	Last modified: 06/19/01

/home/jwacaser/ISE tech interview eval.doc
	Date deleted: 06/12/01
	Permissions: -rw-rw-r--
	Owners login name: jwacaser
	Owners group name: jwacaser
	Size: 68608
	Last accessed: 06/12/01
	Last modified: 06/12/01

Expected Results:  sjwacaser@mosh> safedelchk
safedelchk: scan beginning
safedelchk: removing files safedeleted before 06/20/01
safedelchk: 200 file(s) removed
safedelchk: scan completed
jwacaser@mosh> 

Additional info:
Comment 1 Bernhard Rosenkraenzer 2002-01-18 12:13:53 EST
Since powertools has been discontinued, the official fix is the removal of the
package from current products (sorry).

Note You need to log in before you can comment on or make changes to this bug.