Bug 452361 - gnome terminal "There was an error creating the child process for this terminal"
gnome terminal "There was an error creating the child process for this terminal"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-21 08:29 EDT by Richard W.M. Jones
Modified: 2008-06-21 16:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-21 16:40:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -f -s 1500 from gnome-terminal (1.73 MB, text/plain)
2008-06-21 08:30 EDT, Richard W.M. Jones
no flags Details

  None (edit)
Description Richard W.M. Jones 2008-06-21 08:29:07 EDT
Since recently upgrading something in Rawhide, gnome-terminal
doesn't start up.  I see the error message "There was an error
creating the child process for this terminal".

Version: 2.23.4.2-1.fc10

I don't know if this is related, but xterm doesn't start up
either.  It says:
xterm: Error 32, errno 2: No such file or directory
Reason: get_pty: Not enough ptys

I have set SELinux to Permissive, so it's probably not an SELinux
problem.
Comment 1 Richard W.M. Jones 2008-06-21 08:30:30 EDT
Created attachment 309966 [details]
strace -f -s 1500 from gnome-terminal

This is an strace of gnome-terminal starting up, failing, then
closing down.  It appears to be a pty problem as far as I can see.
Comment 2 Yanko Kaneti 2008-06-21 09:46:45 EDT
initscripts-8.77-1  busted
fixed in initscripts-8.78-1 in koji
Comment 3 Richard W.M. Jones 2008-06-21 16:40:48 EDT
Yes, the new initscripts fixes this.

Note You need to log in before you can comment on or make changes to this bug.