Bug 452371 - Can't print PDF; PS and text work fine
Can't print PDF; PS and text work fine
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-21 11:57 EDT by Horst H. von Brand
Modified: 2008-07-02 06:23 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-02 06:23:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2008-06-21 11:57:03 EDT
Description of problem:
Printing a PDF file shows the job, but it isn't printed. Printing plain text
files or PS works fine.

Version-Release number of selected component (if applicable):
cups-1.3.7-9.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. lpr something.pdf
2.
3.
  
Actual results:
lpq shows the job, but not as active; no printout.

Expected results:


Additional info:
Comment 1 Tim Waugh 2008-06-22 05:54:00 EDT
Please run the printing troubleshooter (Help->Troubleshoot from the
system-config-printer window) and attach the troubleshoot.txt file here.  Thanks.
Comment 2 Horst H. von Brand 2008-06-22 18:12:43 EDT
Run via "ssh -X" (I'm currently away from the machine):

$ system-config-printer
Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 4891,
in <module>
    main(configure_printer, change_ppd)
  File "/usr/share/system-config-printer/system-config-printer.py", line 4861,
in main
    mainwindow = GUI(configure_printer, change_ppd)
  File "/usr/share/system-config-printer/system-config-printer.py", line 525, in
__init__
    self.populateList()
  File "/usr/share/system-config-printer/system-config-printer.py", line 860, in
populateList
    copy = pixbuf.copy ()
AttributeError: 'NoneType' object has no attribute 'copy'
Comment 3 Tim Waugh 2008-06-23 03:52:25 EDT
Run it this way if you like:

python /usr/share/system-config-printer/troubleshoot/__init__.py
Comment 4 Horst H. von Brand 2008-06-23 17:59:32 EDT
After today's round of updates (+ reboot for the kernel) printing works OK.

Running as directed in #3 gets to select the printer (a HP printer), a HP logo
shows up here (via SSH, again), and the print troubleshooter window hangs. The
HP print manager does work, however.

(I'm using SSH as trying to start Gnome or XFCE at the machine just gives a
continous stream of error windows, can't do anything; trying to startx by hand
tells me a stream of:

AUDIT: <date> 32102 X: client 1 rejected from local hosr ( uid=500 gid=500
pid=32101 )
  Auth name: XDM-AUTHORIZATION-1 ID: -1
Protocol not suppported by server
..
Giving up.
xinit: Resource temporarily unavailable (errno 11): unable to connect to X server

Waiting for X server to shut down

xinit: Server error
Comment 5 Tim Waugh 2008-07-02 06:23:24 EDT
(In reply to comment #4)
> Running as directed in #3 gets to select the printer (a HP printer), a HP logo
> shows up here (via SSH, again), and the print troubleshooter window hangs.

I've fixed that bug in the troubleshooter.  Thanks for mentioning it.

Note You need to log in before you can comment on or make changes to this bug.