This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 452385 - add postgresql-jdbc dependency and add classpath
add postgresql-jdbc dependency and add classpath
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-21 14:24 EDT by Michael J. Chudobiak
Modified: 2008-09-10 02:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 02:39:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael J. Chudobiak 2008-06-21 14:24:02 EDT
oo-base does not support postgresql "out of the box", even though
postgresql-jdbc is available in the Fedora repos. Furthermore, after you install
the postgresql-jdbc rpm, you need to activate it in oo-base using:

Tools > Options > Openoffice.org > Java > classpath >
/usr/share/java/postgresql-jdbc.jar

which is totally user-hostile.

I suggest adding a postgresql-jdbc dependency to oo-base, and installing the
/usr/share/java/postgresql-jdbc.jar classpath in oo-base for the user.

This would make it much easier to offer oo-base as an MS-Access replacement.

- Mike
Comment 1 Caolan McNamara 2008-07-08 17:57:22 EDT
We could do that I guess, alternatively perhaps we should add in the postgresql
sdbc (lower-level) driver of
http://dba.openoffice.org/drivers/postgresql/index.html into OOo. Do you have a
preference ?
Comment 2 Michael J. Chudobiak 2008-07-08 21:00:11 EDT
At the moment, the sdbc driver "has issues" and seems to be poorly maintained
(last release = 0.7.5, 2007-08-27). For instance, it currently chokes on
currency-type fields (decimal?).

The jdbc driver works better in my experience, and it is already in the repos,
so hopefully it is just a matter of providing a bit of rpm glue.

However, having ANY postgresql driver readily available in OO by default would
be a big step forward. In an ideal world, both the sdbc and jdbc drivers would
be readily available.

- Mike
Comment 3 Caolan McNamara 2008-07-09 10:07:38 EDT
checked in, will be in >= openoffice.org-2.4.1-17.5
Comment 4 Fedora Update System 2008-08-07 07:06:24 EDT
openoffice.org-2.4.1-17.5.fc9 has been submitted as an update for Fedora 9
Comment 5 Fedora Update System 2008-08-12 14:26:12 EDT
openoffice.org-2.4.1-17.5.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7220
Comment 6 Fedora Update System 2008-08-28 03:47:26 EDT
openoffice.org-2.4.1-17.6.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/openoffice.org-2.4.1-17.6.fc9
Comment 7 Fedora Update System 2008-09-10 02:38:58 EDT
openoffice.org-2.4.1-17.6.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.