Bug 452526 - Can't apply updates because of (bogus) missing dependencies
Can't apply updates because of (bogus) missing dependencies
Status: CLOSED DUPLICATE of bug 249281
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.2
i386 Linux
low Severity high
: rc
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-23 11:15 EDT by Timothy E Miller
Modified: 2009-05-13 17:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-23 12:00:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Timothy E Miller 2008-06-23 11:15:08 EDT
Description of problem:

After a bare metal, kickstart installation of RHEL5.2 Xen dom0, I can not
successfully run 'yum update' because of (bogus) failed dependencies.
The packages that are failing to update (and therefore bombing the entire
process) are:

     net-snmp-utils
     net-snmp-perl
     cups
     ecryptfs-utils

As a side note, but related, installing the 'tk' package has the same problem.

I'm blaming this problem currently on YUM but it could be something RPM 
or RHN Satellite related.

I have looked in our RHN Satellite Server at these packages and they all
have a specified dependency on the *version* but not the *release*.  It
would seem (IMHO) that the yum/rpm/rhn components client side are inserting
the '0' into the release field and it isn't matching up.

Another related, but side, note:  for packages that do not yet have updates
that I want to install (the 'tk' example here), I can specify them in the
kickstart file %packages section and they get installed just fine.

And the last data point that I've collected:  I have scheduled the errata
update for 'cups' and 'net-snmp' in the Satellite Server and the troublesome
packages all get installed.  The outputs below were collected prior to
those errata scheduled events in the Satellite Server.  

Version-Release number of selected component (if applicable):
     yum-3.2.8-9.el5_2.1

     yum as distributed with RHEL5.2 had same problem.

I'm sure there are tons 
VARIOUS OUTPUTS:

# yum list updates
Loading "rhnplugin" plugin
Loading "security" plugin
Loading "downloadonly" plugin
rhel-i386-server-5-wfu-de 100% |=========================| 1.2 kB    00:00     
rhel-i386-server-5-wfu-xe 100% |=========================| 1.2 kB    00:00     
rhel-i386-server-5-backup 100% |=========================| 1.2 kB    00:00     
rhel-i386-server-5        100% |=========================| 1.2 kB    00:00     
rhel-i386-server-suppleme 100% |=========================| 1.2 kB    00:00     
rhel-i386-server-vt-5     100% |=========================| 1.2 kB    00:00     
rhel-i386-server-hts-5    100% |=========================| 1.2 kB    00:00     
rhn-tools-rhel-i386-serve 100% |=========================| 1.2 kB    00:00     
Skipping security plugin, no data
Updated Packages
cups.i386                                1:1.2.4-11.18.el5_2.1  rhel-i386-server
cups-libs.i386                           1:1.2.4-11.18.el5_2.1  rhel-i386-server
dhcpv6-client.i386                       1.0.10-4.el5_2.2       rhel-i386-server
freetype.i386                            2.2.1-20.el5_2         rhel-i386-server
gnutls.i386                              1.4.1-3.el5_1          rhel-i386-server
ipsec-tools.i386                         0.6.5-9.el5_2.1        rhel-i386-server
kernel.i686                              2.6.18-92.1.1.el5      rhel-i386-server
kernel-xen.i686                          2.6.18-92.1.1.el5      rhel-i386-server
kernel-xen-devel.i686                    2.6.18-92.1.1.el5      rhel-i386-server
net-snmp.i386                            1:5.3.1-24.el5_2.1     rhel-i386-server
net-snmp-libs.i386                       1:5.3.1-24.el5_2.1     rhel-i386-server
net-snmp-perl.i386                       1:5.3.1-24.el5_2.1     rhel-i386-server
net-snmp-utils.i386                      1:5.3.1-24.el5_2.1     rhel-i386-server
perl.i386                                4:5.8.8-10.el5_2.3     rhel-i386-server
perl-suidperl.i386                       4:5.8.8-10.el5_2.3     rhel-i386-server
redhat-release-notes.i386                5Server-15             rhel-i386-server
tzdata.noarch                            2008b-3.el5            rhel-i386-server
xen.i386                                 3.0.3-64.el5_2.1       rhel-i386-server
xen-libs.i386                            3.0.3-64.el5_2.1       rhel-i386-server

# yum list | grep -E '(yum|rpm)'
rpm.i386                                 4.4.2-48.el5           installed       
rpm-libs.i386                            4.4.2-48.el5           installed       
rpm-python.i386                          4.4.2-48.el5           installed       
yum.noarch                               3.2.8-9.el5_2.1        installed       
yum-downloadonly.noarch                  1.1.10-9.el5           installed       
yum-metadata-parser.i386                 1.1.2-2.el5            installed       
yum-rhn-plugin.noarch                    0.5.3-6.el5_2.6        installed       
yum-security.noarch                      1.1.10-9.el5           installed       
yum-updatesd.noarch                      1:0.9-2.el5            installed       
redhat-rpm-config.noarch                 8.0.45-24.el5          rhel-i386-server
rpm-build.i386                           4.4.2-48.el5           rhel-i386-server
rpm-devel.i386                           4.4.2-48.el5           rhel-i386-server
yum-aliases.noarch                       1.1.10-9.el5           rhel-i386-server
yum-basearchonly.noarch                  1.1.10-9.el5           rhel-i386-server
yum-changelog.noarch                     1.1.10-9.el5           rhel-i386-server
yum-filter-data.noarch                   1.1.10-9.el5           rhel-i386-server
yum-kmod.noarch                          1.1.10-9.el5           rhel-i386-server
yum-list-data.noarch                     1.1.10-9.el5           rhel-i386-server
yum-protect-packages.noarch              1.1.10-9.el5           rhel-i386-server
yum-protectbase.noarch                   1.1.10-9.el5           rhel-i386-server
yum-skip-broken.noarch                   1.1.10-9.el5           rhel-i386-server
yum-updateonboot.noarch                  1.1.10-9.el5           rhel-i386-server
yum-utils.noarch                         1.1.10-9.el5           rhel-i386-server
yum-versionlock.noarch                   1.1.10-9.el5           rhel-i386-server

# rpm -qa | grep net-snmp
net-snmp-libs-5.3.1-24.el5
net-snmp-5.3.1-24.el5
net-snmp-perl-5.3.1-24.el5
net-snmp-utils-5.3.1-24.el5

# rpm -qa | grep cups
cups-libs-1.2.4-11.18.el5
cups-1.2.4-11.18.el5

# yum update
Loading "rhnplugin" plugin
Loading "security" plugin
Loading "downloadonly" plugin
rhel-i386-server-5-wfu-de 100% |=========================| 1.2 kB    00:00     
rhel-i386-server-5-wfu-xe 100% |=========================| 1.2 kB    00:00     
rhel-i386-server-5-backup 100% |=========================| 1.2 kB    00:00     
rhel-i386-server-5        100% |=========================| 1.2 kB    00:00     
rhel-i386-server-suppleme 100% |=========================| 1.2 kB    00:00     
rhel-i386-server-vt-5     100% |=========================| 1.2 kB    00:00     
rhel-i386-server-hts-5    100% |=========================| 1.2 kB    00:00     
rhn-tools-rhel-i386-serve 100% |=========================| 1.2 kB    00:00     
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package cups-libs.i386 1:1.2.4-11.18.el5_2.1 set to be updated
---> Package kernel.i686 0:2.6.18-92.1.1.el5 set to be installed
---> Package redhat-release-notes.i386 0:5Server-15 set to be updated
---> Package kernel-xen.i686 0:2.6.18-92.1.1.el5 set to be installed
---> Package kernel-xen-devel.i686 0:2.6.18-92.1.1.el5 set to be installed
---> Package net-snmp-perl.i386 1:5.3.1-24.el5_2.1 set to be updated
--> Processing Dependency: net-snmp = 1:5.3.1-0 for package: net-snmp-perl
---> Package tzdata.noarch 0:2008b-3.el5 set to be updated
---> Package ipsec-tools.i386 0:0.6.5-9.el5_2.1 set to be updated
---> Package dhcpv6-client.i386 0:1.0.10-4.el5_2.2 set to be updated
---> Package net-snmp-utils.i386 1:5.3.1-24.el5_2.1 set to be updated
--> Processing Dependency: net-snmp = 1:5.3.1-0 for package: net-snmp-utils
---> Package freetype.i386 0:2.2.1-20.el5_2 set to be updated
---> Package perl.i386 4:5.8.8-10.el5_2.3 set to be updated
---> Package net-snmp-libs.i386 1:5.3.1-24.el5_2.1 set to be updated
---> Package perl-suidperl.i386 4:5.8.8-10.el5_2.3 set to be updated
---> Package gnutls.i386 0:1.4.1-3.el5_1 set to be updated
---> Package xen-libs.i386 0:3.0.3-64.el5_2.1 set to be updated
---> Package xen.i386 0:3.0.3-64.el5_2.1 set to be updated
---> Package net-snmp.i386 1:5.3.1-24.el5_2.1 set to be updated
---> Package cups.i386 1:1.2.4-11.18.el5_2.1 set to be updated
--> Processing Dependency: cups-libs = 1:1.2.4-0 for package: cups
--> Processing Conflict: ecryptfs-utils conflicts kernel < 2.6.18-61
--> Processing Conflict: ecryptfs-utils conflicts kernel < 2.6.18-61
--> Finished Dependency Resolution
Error: Missing Dependency: net-snmp = 1:5.3.1-0 is needed by package net-snmp-utils
Error: Missing Dependency: cups-libs = 1:1.2.4-0 is needed by package cups
Error: Missing Dependency: net-snmp = 1:5.3.1-0 is needed by package net-snmp-perl
Error: ecryptfs-utils conflicts with kernel < 2.6.18-61

# yum install tk
Loading "rhnplugin" plugin
Loading "security" plugin
Loading "downloadonly" plugin
rhel-i386-server-5-wfu-de 100% |=========================| 1.2 kB    00:00     
rhel-i386-server-5-wfu-xe 100% |=========================| 1.2 kB    00:00     
rhel-i386-server-5-backup 100% |=========================| 1.2 kB    00:00     
rhel-i386-server-5        100% |=========================| 1.2 kB    00:00     
rhel-i386-server-suppleme 100% |=========================| 1.2 kB    00:00     
rhel-i386-server-vt-5     100% |=========================| 1.2 kB    00:00     
rhel-i386-server-hts-5    100% |=========================| 1.2 kB    00:00     
rhn-tools-rhel-i386-serve 100% |=========================| 1.2 kB    00:00     
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package tk.i386 0:8.4.13-5.el5_1.1 set to be updated
--> Processing Dependency: tcl = 8.4.13-0 for package: tk
--> Finished Dependency Resolution
Error: Missing Dependency: tcl = 8.4.13-0 is needed by package tk
Comment 1 Timothy E Miller 2008-06-23 11:26:35 EDT
This might be related to Bug #446135 but there aren't enough (or any) details
in the bug report to be sure.  It "smells" similar though.

Also looks to be highly related to Bug 448851 but I'm using RHN Sat 4.2.1.
Comment 2 Timothy E Miller 2008-06-23 11:34:47 EDT
Submitted RHN Satellite Support Request just now (1837298)
Comment 3 James Antill 2008-06-23 12:00:43 EDT

*** This bug has been marked as a duplicate of 249281 ***

Note You need to log in before you can comment on or make changes to this bug.