Bug 452645 - Latest alc_env fixes broke system man path
Latest alc_env fixes broke system man path
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: alliance (Show other bugs)
9
All Linux
high Severity low
: ---
: ---
Assigned To: Chitlesh GOORAH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-24 04:45 EDT by Adam Pribyl
Modified: 2008-09-16 19:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-16 19:22:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Pribyl 2008-06-24 04:45:08 EDT
Description of problem:
With the latest version of alc_env.sh the manpath is allways set to
$ man --path
/usr/lib/alliance/man
ONLY!

Version-Release number of selected component (if applicable):
alliance-5.0-16.20070718snap.fc8



Additional info:
This section of alc_env.sh causes this:

 if [ -z "${MANPATH}" ]; then
   MANPATH=$ALLIANCE_TOP/man
 else
   MANPATH=$MANPATH:$ALLIANCE_TOP/man:
 fi
 export MANPATH

By default there is no $MANPATH variable on Fedora system, however when it is
set, then only MANPATH is used. The man path is configured by /etc/man.config.
Default output of
# man --path
/usr/kerberos/man:/usr/local/share/man:/usr/share/man/cs:/usr/share/man:/usr/X11R6/man:/usr/lib/alliance/man:/usr/man:/usr/local/man

The above code leads to that no man page except those from alliance are
reachable with this shell settings. You either should use man --path to get path
list or add alliance man pages to man.config.
Comment 1 Balaji G 2008-06-24 11:54:27 EDT
Changing Status to ASSIGNED

Cheers.
Balaji
Comment 2 Chitlesh GOORAH 2008-07-26 05:18:39 EDT
(In reply to comment #1)
> Changing Status to ASSIGNED
> 
> Cheers.
> Balaji

Why ?
Comment 3 Adam Pribyl 2008-07-26 16:17:50 EDT
Because the problem is obvious and also a fix is described. This leads probably
some bugzapper to assuption, that this bug could be easily threaten by its
owner. Bugs in NEW status mean - we do not care.
Comment 4 Fedora Update System 2008-09-15 17:11:41 EDT
alliance-5.0-21.20070718snap.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/alliance-5.0-21.20070718snap.fc9
Comment 5 Fedora Update System 2008-09-15 17:11:46 EDT
alliance-5.0-21.20070718snap.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/alliance-5.0-21.20070718snap.fc8
Comment 6 Fedora Update System 2008-09-16 19:22:28 EDT
alliance-5.0-21.20070718snap.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2008-09-16 19:23:54 EDT
alliance-5.0-21.20070718snap.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.