Bug 452858 - SELinux is preventing logrotate (logrotate_t) "read write" to socket (crond_t).
SELinux is preventing logrotate (logrotate_t) "read write" to socket (crond_t).
Status: CLOSED DUPLICATE of bug 452857
Product: Fedora
Classification: Fedora
Component: nss_ldap (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Nalin Dahyabhai
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-25 09:48 EDT by Jeff Moyer
Modified: 2008-06-26 07:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-26 07:57:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Moyer 2008-06-25 09:48:32 EDT
Description of problem:

Summary:

SELinux is preventing logrotate (logrotate_t) "read write" to socket (crond_t).

Detailed Description:

SELinux denied access requested by logrotate. It is not expected that this
access is required by logrotate and this access may signal an intrusion attempt.
It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:logrotate_t:s0-s0:c0.c1023
Target Context                system_u:system_r:crond_t:s0-s0:c0.c1023
Target Objects                socket [ tcp_socket ]
Source                        logrotate
Source Path                   /usr/sbin/logrotate
Port                          <Unknown>
Host                          segfault.boston.devel.redhat.com
Source RPM Packages           logrotate-3.7.6-5.fc9
Target RPM Packages           
Policy RPM                    selinux-policy-3.3.1-64.fc9
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     segfault.boston.devel.redhat.com
Platform                      Linux segfault.boston.devel.redhat.com
                              2.6.25.6-55.fc9.x86_64 #1 SMP Tue Jun 10 16:05:21
                              EDT 2008 x86_64 x86_64
Alert Count                   1
First Seen                    Wed 25 Jun 2008 04:33:51 AM EDT
Last Seen                     Wed 25 Jun 2008 04:33:51 AM EDT
Local ID                      93bdb4cc-fc33-4ec3-9372-aa730a01e43d
Line Numbers                  

Raw Audit Messages            

host=segfault.boston.devel.redhat.com type=AVC msg=audit(1214382831.122:278):
avc:  denied  { read write } for  pid=27734 comm="logrotate"
path="socket:[2058152]" dev=sockfs ino=2058152
scontext=system_u:system_r:logrotate_t:s0-s0:c0.c1023
tcontext=system_u:system_r:crond_t:s0-s0:c0.c1023 tclass=tcp_socket

host=segfault.boston.devel.redhat.com type=SYSCALL
msg=audit(1214382831.122:278): arch=c000003e syscall=59 success=yes exit=0
a0=1b606d0 a1=1b60630 a2=1b5f140 a3=32c3367a70 items=0 ppid=27732 pid=27734
auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=27
comm="logrotate" exe="/usr/sbin/logrotate"
subj=system_u:system_r:logrotate_t:s0-s0:c0.c1023 key=(null)


Not sure if this is a dup of 452857.
Comment 1 Daniel Walsh 2008-06-26 07:57:02 EDT
nss_ldap...



*** This bug has been marked as a duplicate of 452857 ***

Note You need to log in before you can comment on or make changes to this bug.