Bug 452987 - Logging needed for operational events
Logging needed for operational events
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-qmf (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chuck Rolke
Jeff Needle
:
Depends On:
Blocks: 924372 924374
  Show dependency treegraph
 
Reported: 2008-06-26 09:38 EDT by Ted Ross
Modified: 2013-03-21 12:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 924372 924374 (view as bug list)
Environment:
Last Closed: 2013-03-21 12:06:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ted Ross 2008-06-26 09:38:18 EDT
The following events need to be logged (to file, syslog, etc.) during broker
operation:

1) open/close connection
2) attach session
3) create/delete queue
4) bind/unbind of queue to exchange
5) drop of unroutable message by exchange
6) exceed user-configured thresholds (queue size (octets), queue size
(messages), message age on queue)
7) periodic notification of message rates on broker
Comment 1 Ted Ross 2008-12-04 11:16:46 EST
I've retargetted this bug for 1.1.1 because it has been partially resolved.

The remaining un-done events from above are:

2) attach session
5) drop of unroutable message by exchange
6) exceed user-configured thresholds (queue size (octets), queue size
(messages), message age on queue)
7) periodic notification of message rates on broker
Comment 3 Justin Ross 2013-03-21 07:36:46 EDT
Chuck, some of your recent work for 2.3 may have addressed this.
Comment 4 Chuck Rolke 2013-03-21 09:48:21 EDT
Current status as of 2.3:

2) attach session

yes - shipping

5) drop of unroutable message by exchange

no - no event nor log message but counted as discardsNoRoute

6) exceed user-configured thresholds (queue size (octets), queue size
(messages), message age on queue)

yes - shipping

7) periodic notification of message rates on broker

no
Comment 5 Justin Ross 2013-03-21 12:05:39 EDT
Thanks, Chuck.

Issue 5: https://bugzilla.redhat.com/show_bug.cgi?id=924372
Issue 7: https://bugzilla.redhat.com/show_bug.cgi?id=924374

-> CLOSED

Note You need to log in before you can comment on or make changes to this bug.