Bug 453001 - GFS2: Running yum upgrade on RHEL 5.2 fails with rpm conflicts
GFS2: Running yum upgrade on RHEL 5.2 fails with rpm conflicts
Status: CLOSED DUPLICATE of bug 445591
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
high Severity low
: rc
: ---
Assigned To: Chris Feist
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-26 10:55 EDT by Jan Pazdziora
Modified: 2009-05-27 23:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-26 15:37:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2008-06-26 10:55:35 EDT
Description of problem:

Running yum upgrade on RHEL 5.2 fails with rpm conflicts.

Version-Release number of selected component (if applicable):

kmod-gfs2-xen-1.92-1.1.el5_2.2

How reproducible:

Deterministic.

Steps to Reproduce:
1. Install RHEL 5.2. Make sure you check everything. After install, you should
have the following package installed:

   # rpm -qa | grep gfs | sort
   gfs2-utils-0.1.44-1.el5
   gfs-utils-0.1.12-1.el5
   kmod-gfs-0.1.19-7.el5
   kmod-gfs2-1.52-1.16.el5
   kmod-gfs2-xen-1.52-1.16.el5
   kmod-gfs-xen-0.1.19-7.el5

2. Make sure your system is registered to RHN / RHN Satellite and that you have
all available child channels checked.
3. Run yum upgrade.
  
Actual results:

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 kernel-xen-devel        i686       2.6.18-92.1.6.el5  rhel-i386-server-5  4.8 M
 kmod-gfs                i686       0.1.23-5.el5    
rhel-i386-server-cluster-storage-5  138 k
 kmod-gfs-xen            i686       0.1.23-5.el5    
rhel-i386-server-cluster-storage-5  138 k
 kmod-gfs2               i686       1.92-1.1.el5_2.2 
rhel-i386-server-cluster-storage-5  434 k
 kmod-gfs2-xen           i686       1.92-1.1.el5_2.2 
rhel-i386-server-cluster-storage-5  426 k
 openib-perftest         i386       1.2-6.el5_1.1    rhel-i386-server-5   69 k
     replacing  perftest.i386 1.2-10.el5

Updating:
 Deployment_Guide-en-US  noarch     5.2-11           rhel-i386-server-5  3.5 M
 Virtualization-en-US    noarch     5.2-9            rhel-i386-server-vt-5  1.7 M

[...]

Total download size: 138 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /etc/depmod.d/gfs2.conf from install of kmod-gfs2-xen-1.92-1.1.el5_2.2
conflicts with file from package kmod-gfs2-1.52-1.16.el5
  file /etc/depmod.d/gfs2.conf from install of kmod-gfs2-xen-1.92-1.1.el5_2.2
conflicts with file from package kmod-gfs2-xen-1.52-1.16.el5
  file /etc/depmod.d/gfs2.conf from install of kmod-gfs2-1.92-1.1.el5_2.2
conflicts with file from package kmod-gfs2-1.52-1.16.el5
  file /etc/depmod.d/gfs2.conf from install of kmod-gfs2-1.92-1.1.el5_2.2
conflicts with file from package kmod-gfs2-xen-1.52-1.16.el5

Expected results:

No conflicts, clean update.

Additional info:
Comment 1 RHEL Product and Program Management 2008-06-26 10:56:52 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Chris Feist 2008-06-26 15:37:39 EDT
The version of gfs2-kmod in 5.2 is 1.92-1.1.el5, it appears as though you're
using the gfs2-kmod from 5.1.

There is a known issue with upgrading gfs2-kmod from 5.1 to 5.2 (without having
yum-kmod installed).

*** This bug has been marked as a duplicate of 445591 ***
Comment 3 Jan Pazdziora 2008-06-26 15:57:24 EDT
The 1.92-1.1.el5 might have come from 5.1, but if was installed on my system
using ks-rhel-i386-server-5-u2. So the problem is present post-5.2 as well.

Note You need to log in before you can comment on or make changes to this bug.