This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 453008 - XineramaQueryExtension is returning false positives in desktop-effects
XineramaQueryExtension is returning false positives in desktop-effects
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: compiz (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Kristian Høgsberg
desktop-bugs@redhat.com
: Reopened
Depends On:
Blocks: 531223
  Show dependency treegraph
 
Reported: 2008-06-26 11:46 EDT by Alan Matsuoka
Modified: 2009-11-25 05:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 531223 (view as bug list)
Environment:
Last Closed: 2009-10-27 07:59:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport (1.49 MB, application/x-bzip2)
2008-06-26 11:46 EDT, Alan Matsuoka
no flags Details
dmesg from sosreport (21.32 KB, text/plain)
2008-06-27 08:36 EDT, Matěj Cepl
no flags Details
xorg.conf from sosreport (1.34 KB, text/plain)
2008-06-27 08:36 EDT, Matěj Cepl
no flags Details
Xorg.0.log from sosreport (25.63 KB, text/plain)
2008-06-27 08:36 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Alan Matsuoka 2008-06-26 11:46:53 EDT
Description of problem:
When enabling desktop-effects we are getting the error:
"Desktop effects do not work with Xinerama"
when xinerama is not enabled.

How reproducible:
Every time.

Steps to Reproduce:
1. Install compiz.
2. Click on desktop-effects.
3. Witness the error.

Actual results:
You get the before mentioned error.

Expected results:
you should be able to enable compiz.

Additional info:
We fixed the problem with a little bandaid.  we modified the following line to
always return false in the desktop-effects.c

Original:
   if (XineramaQueryExtension (GDK_DISPLAY (), &dummy1, &dummy2))
       return TRUE;

   return FALSE;

Edited:
   if (XineramaQueryExtension (GDK_DISPLAY (), &dummy1, &dummy2))
       return FALSE;

I would include a patch but this isn't really a fix, now it will never show a
posative if xinerama is installed.  I think the problem is in the
XineramaQueryExtension call.

Notes from SEG:

the has_xinerama code has been expunged from the upstream sources.
Comment 1 Alan Matsuoka 2008-06-26 11:46:54 EDT
Created attachment 310346 [details]
sosreport
Comment 2 Matěj Cepl 2008-06-27 08:36:30 EDT
Created attachment 310429 [details]
dmesg from sosreport
Comment 3 Matěj Cepl 2008-06-27 08:36:41 EDT
Created attachment 310430 [details]
xorg.conf from sosreport
Comment 4 Matěj Cepl 2008-06-27 08:36:51 EDT
Created attachment 310431 [details]
Xorg.0.log from sosreport
Comment 5 Matěj Cepl 2008-06-27 08:39:26 EDT
Thanks for the report. We are sorry that we cannot help you with your problem,
but we are not able to support binary-only drivers. If you would be able to
reproduce this issue using only open source software, please, reopen this bug
with the additional information, but in meantime I have no choice than to close
this bug as CANTFIX (because we really cannot fix it).

For users who are experiencing problems installing, configuring, or using the
unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides
indirect customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and passes them on to
Nvidia engineers for investigation.  Once they've isolated a particular problem,
it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have
experienced the particular problem may be able to assist.  If there is a real
bug occuring, Nvidia will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system releases that they
officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring
technical support may also find the various X.Org, XFree86, and Red Hat mailing
lists helpful in finding assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo
Comment 10 RHEL Product and Program Management 2009-03-26 12:56:24 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 11 Alan Matsuoka 2009-03-26 13:37:39 EDT
Moving to 5.5
Comment 12 Charlie Wyse 2009-09-09 14:13:01 EDT
Just to note about the fix submitted with the Issue Tracker.  When you enable/disable the composite extension it checks for xinerama and fails if it's activated but will work if TwinView is used.  (TwinView is supposed to be nvidias version of xinerama).  It might be more properly coded if desktop-effects can really check for xinerama and not twinview or xinerama.  That way people with dual displays can use compiz as long as they don't use the buggy xinerama.
Comment 19 Alan Matsuoka 2009-10-27 07:59:41 EDT
The customer wants this bug fixed in 6.0. I've cloned this BZ for 6.0 (#53123).
Comment 20 Alexander Todorov 2009-11-25 05:55:12 EST
I have seen this issue as well. However there's another one which could be similar or duplicate. When starting X with -xinerama and running xdpyinfo I get:

number of extensions:    32
 ... skip ...
    XINERAMA
 ... skip ...

Is it the same or a different one?

Note You need to log in before you can comment on or make changes to this bug.