Bug 45304 - crond executing twice with two seconds interval
crond executing twice with two seconds interval
Status: CLOSED DUPLICATE of bug 29868
Product: Red Hat Linux
Classification: Retired
Component: vixie-cron (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-21 06:05 EDT by Ola Thoresen
Modified: 2007-04-18 12:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-05 00:41:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ola Thoresen 2001-06-21 06:05:10 EDT
Description of Problem:

Under some conditions crond is executing twice in a few seconds.
This seems to be the same bug as reported in
http://www.google.com/search?q=cache:LTQWh9drdB8:sunsite.bilkent.edu.tr/pub/sun-info/sunspots/v9n41+cron+bug+twice
(from feb. 1990! =;-)

The bug was probably introduced between 
vixie-cron-3.0.1-56 and 
vixie-cron-3.0.1-61

We have several servers running both versions, and the bug is only present on the ones with -61.

A sample from the logfiles shows
Jun 21 08:09:59 intentia CROND[31492]: (root) CMD (   /sbin/rmmod -as) 
Jun 21 08:09:59 intentia CROND[31494]: (root) CMD (/usr/bin/uptime >> /var/log/uptime.log) 
Jun 21 08:10:01 intentia CROND[31503]: (root) CMD (   /sbin/rmmod -as) 
Jun 21 08:10:01 intentia CROND[31505]: (root) CMD (/usr/bin/uptime >> /var/log/uptime.log) 

This happens from time to time, with no aparent reason - one to two times a day.  

It does not seem to be related to either the cpu-load, memoy-usage or other stress of the machines.
Comment 1 Thomas J. Baker 2001-12-06 07:58:30 EST
I am experiencing this problem as well on a RedHat 7.0 system. On our system, it
seems like cron is timing it's minutes incorrectly. It often runs at HH:MM:00
and HH:MM:59. This is causing us a few problems with some oracle stuff.
Comment 2 Timothy Burt 2001-12-14 11:48:13 EST
Same here.  Redhat 7.0, patched up to the latest.

Kernel 2.2.19-7.0.10

Here is a syslog snippit:

Dec 14 05:00:59 host111 CROND[12145]: (root) CMD (run-parts /etc/cron.hourly)
Dec 14 05:00:59 host111 CROND[12146]: (root) CMD (/root/mirror.rsync 
> /dev/null 2>&1)
Dec 14 05:01:00 host111 CROND[12177]: (root) CMD (run-parts /etc/cron.hourly)
Dec 14 05:01:00 host111 CROND[12178]: (root) CMD (/root/mirror.rsync 
> /dev/null 2>&1)

What gives?  This bug has been open for six months.  Is there a reason why it 
is being ignored?
Comment 3 Jan "Yenya" Kasprzak 2002-01-10 05:49:53 EST
I have also ran into this bug - vixie-cron-3.0.1-61, Red Hat 7.0 system.
I have upgraded to -63 (from RH7.2) and we'll se if this gets fixed.

-Yenya
Comment 4 Steve Pettypiece 2002-04-19 16:08:31 EDT
I have this problem as well. Has there been any progress made on resolving this 
issue?
Comment 5 Jan "Yenya" Kasprzak 2002-04-22 03:17:40 EDT
Yes. The upgrade to 3.0.1-63 (from Red Hat Linux 7.2) fixes the problem.
Comment 6 Jens Petersen 2002-08-23 05:56:43 EDT

*** This bug has been marked as a duplicate of 29868 ***

Note You need to log in before you can comment on or make changes to this bug.