Bug 453125 - gnome-settings-daemon tries to take control even if not using gnome desktop
gnome-settings-daemon tries to take control even if not using gnome desktop
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-27 09:09 EDT by nvwarr
Modified: 2008-11-04 05:37 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-04 05:37:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nvwarr 2008-06-27 09:09:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061712 Fedora/3.0-1.fc9 Firefox/3.0

Description of problem:
Starting any gnome application seems to start up gnome-settings-daemon, which then changes X resources, starts a screensaver, changes the wallpaper, reconfigures the keyboard etc. This is done, even when not using a gnome desktop environment.

The most annoying problem is that it sometimes sets keyboard accessibility to "slow keys" (although this is not checked in gnome-keyboard-properties) which causes the keyboard to fail to work properly, so that there is a long pause after a key is pressed, then two characters appear, making it impossible to type anything. In that state, I have to start gnome-keyboard-properties, select "slow keys" and then deselect it, to get normal keyboard operation.

I use fvwm, but in my search for the cause of the problem I came across posts from people using other window managers. As it is rather counter-intuitive to suspect gnome when you are running with another window manager, I expect most of the people who have experienced this problem haven't been able to track it down. I first thought that it was a bug in the x11 keyboard driver, but that seems not to be the case. The ICE window manager has also been suspected.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Use a window manager other than gnome.
2. Start a gnome application like gnome-sound-properties.
3. Watch gnome-settings-daemon change the desktop background and reconfigure a whole load of other things.

Actual Results:
gnome takes over everything

Expected Results:
It should not be assumed that just because the user starts a single gnome application, that he or she wishes to have a completely gnome controlled system.

Additional info:
Downgrading back to gnome-settings-daemon-2.22.1-0.2008.03.26.7.fc9 (I was using gnome-settings-daemon-2.22.2.1-1.fc9) at least stops it from taking control over the desktop wallpaper. However, it still starts a screensaver which overrides my settings, so it doesn't power off the monitor after a while. It also changes my X resources. I'm not sure about the keyboard problem because that only seems to occur once or twice a day.
Comment 1 nvwarr 2008-08-01 08:30:05 EDT
(In reply to comment #0)
> From Bugzilla Helper:
> User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061712
Fedora/3.0-1.fc9 Firefox/3.0
> 
> Description of problem:
> Starting any gnome application seems to start up gnome-settings-daemon, which
then changes X resources, starts a screensaver, changes the wallpaper,
reconfigures the keyboard etc. This is done, even when not using a gnome desktop
environment.
> 
> The most annoying problem is that it sometimes sets keyboard accessibility to
"slow keys" (although this is not checked in gnome-keyboard-properties) which
causes the keyboard to fail to work properly, so that there is a long pause
after a key is pressed, then two characters appear, making it impossible to type
anything. In that state, I have to start gnome-keyboard-properties, select "slow
keys" and then deselect it, to get normal keyboard operation.
> 
> I use fvwm, but in my search for the cause of the problem I came across posts
from people using other window managers. As it is rather counter-intuitive to
suspect gnome when you are running with another window manager, I expect most of
the people who have experienced this problem haven't been able to track it down.
I first thought that it was a bug in the x11 keyboard driver, but that seems not
to be the case. The ICE window manager has also been suspected.
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> Always
> 
> 
> Steps to Reproduce:
> 1. Use a window manager other than gnome.
> 2. Start a gnome application like gnome-sound-properties.
> 3. Watch gnome-settings-daemon change the desktop background and reconfigure a
whole load of other things.
> 
> Actual Results:
> gnome takes over everything
> 
> Expected Results:
> It should not be assumed that just because the user starts a single gnome
application, that he or she wishes to have a completely gnome controlled system.
> 
> Additional info:
> Downgrading back to gnome-settings-daemon-2.22.1-0.2008.03.26.7.fc9 (I was
using gnome-settings-daemon-2.22.2.1-1.fc9) at least stops it from taking
control over the desktop wallpaper. However, it still starts a screensaver which
overrides my settings, so it doesn't power off the monitor after a while. It
also changes my X resources. I'm not sure about the keyboard problem because
that only seems to occur once or twice a day.

This problem persists, as does the problem of screwing up the keyboard, with
gnome-settings-daemon-2.22.2.1-2.fc9.
Comment 2 nvwarr 2008-11-04 05:37:05 EST
It seems the changing of background, xrdb settings and screensaver are "features" not bugs. i.e.

gconftool-2 -s /apps/gnome_settings_daemon/plugins/xrdb/active -t bool false
gconftool-2 -s /apps/gnome_settings_daemon/plugins/background/active -t bool false
gconftool-2 -s /apps/gnome_settings_daemon/plugins/screensaver/active -t bool false

turns them off. I rather think that they should be off by default if gnome is not being used as window manager.

The problem of "slow keys" being turned on somehow is apparently unrelated. In fact there were two problems. One was slow keys being turned on in the first place, and I still haven't found out why. The other was a bug in Xorg which caused it to repeat keys when slow keys was on, which has been fixed in updates. The issue of slow keys being turned on by something (as yet unknown) is bug 445898, so I'm closing this bug entry.

Note You need to log in before you can comment on or make changes to this bug.