Bug 453242 - guide does not tell you which packages you need to run an NFS server
guide does not tell you which packages you need to run an NFS server
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Deployment_Guide (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Jaromir Hradilek
ecs-bugs
: Documentation
Depends On:
Blocks: 561649
  Show dependency treegraph
 
Reported: 2008-06-28 05:53 EDT by Murray McAllister
Modified: 2016-06-17 17:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-16 18:47:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Murray McAllister 2008-06-28 05:53:28 EDT
Description of problem:

The Deployment Guide does not detail which packages are required to run an NFS
server.

Additional info:

Maybe a statement added to
<http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/en-US/RHEL510/Deployment_Guide/s2-nfs-how-daemons.html>
saying you need to install nfs-utils, nfs-utils-lib, and portmap.

This might not be required. I tried to do this on Fedora but could not find
documentation for which packages I needed anywhere. Does Red Hat Enterprise
Linux still use portmap? If not (like Fedora), you need the "rpcbind" package,
instead of "portmap".

Cheers.
Comment 3 Florian Nadge 2010-05-24 08:04:31 EDT
Does
Comment 4 Florian Nadge 2010-05-24 08:07:18 EDT
Sorry, does REHL 5 still use the portmap service or does it already replaced by the rpcbind service?
Comment 7 Steve Dickson 2010-05-26 13:05:30 EDT
Yes... RHEL5 still uses the portmapper
Comment 8 Florian Nadge 2010-05-28 07:50:36 EDT
So basically, could I say that the packages  nfs-utils, nfs-utils-lib, and portmap are required to run an NFS server???

Thanks
Comment 9 Florian Nadge 2010-06-09 05:47:19 EDT
Will add: 
To run an NFS server you need to install the packages  nfs-utils, nfs-utils-lib, and portmap.

Please, let me know whether this right. Many thanks
Comment 11 RHEL Product and Program Management 2010-08-09 14:29:08 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 12 Jaromir Hradilek 2010-10-21 12:50:48 EDT
Fixed in Red_Hat_Enterprise_Linux-Deployment_Guide-5-en-US-6-24.el5.

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html/Deployment_Guide/ch-nfs.html#s2-nfs-how-daemons
Comment 13 Andrew Ross 2010-10-21 17:11:17 EDT
Verified: Red_Hat_Enterprise_Linux-Deployment_Guide-5-web-en-US-6-24.el5

" To use NFS on your system, make sure you have the nfs-utils, nfs-utils-lib, and portmap packages installed. "

Note You need to log in before you can comment on or make changes to this bug.