Bug 453293 - Pidgin prompting for unsaved passwords after NetworkManager reconnects
Pidgin prompting for unsaved passwords after NetworkManager reconnects
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-29 01:56 EDT by Naveed Hasan
Modified: 2009-01-13 09:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-13 09:34:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Naveed Hasan 2008-06-29 01:56:31 EDT
Since recently upgrading to Fedora 9 and with all current updates, including
pidgin-2.4.2-1.fc9.x86_64 - pidgin always asks for unsaved passwords for all
protocols after a resume. It did not used to do that in Fedora 8, where it would
reconnect without prompting for passwords again after a suspend / resume cycle.
Any ideas about this issue?

The one possibly relevant configuration change I can think of is that I am now
using NetworkManager-0.7.0-0.9.4.svn3675.fc9.x86_64 to manage my network
connections whereas before I was using the old style network service provided by
initscripts. This is probably not the source of this change in behavior, but I
am not sure.

Thanks for your help!
Comment 1 Naveed Hasan 2008-08-04 13:37:02 EDT
After a bit more experience with this issue, I am fairly sure this is a result of moving to NetworkManager. Whenever I disable networking via the applet and reenable shortly afterwards, pidgin apparently forgets all of my entered passwords and reprompts for all of them. Suspending and resuming is just one of the times that NetworkManager causes this problem.

Other applications in which I don't have the password saved in any serialized state don't have this issue. Hopefully this helps point towards the right bit of code.
Comment 2 Naveed Hasan 2008-08-04 14:00:49 EDT
A shot in the dark here, but this may be the same resolution as another NetworkManager issue I was running into recently - https://bugzilla.redhat.com/show_bug.cgi?id=456743#c1
Comment 3 Stu Tomlinson 2009-01-13 09:34:35 EST
This was fixed in Pidgin 2.5.3

Note You need to log in before you can comment on or make changes to this bug.