Bug 453336 - Frequent crashes on javascript heavy pages
Frequent crashes on javascript heavy pages
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Gecko Maintainer
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-29 17:26 EDT by daryl herzmann
Modified: 2008-07-21 10:57 EDT (History)
0 users

See Also:
Fixed In Version: firefox-3.0.1-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-21 10:57:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
firefox bt while on youtube mail (12.14 KB, text/plain)
2008-06-29 17:26 EDT, daryl herzmann
no flags Details
firefox bt with java plugin (7.86 KB, text/plain)
2008-06-29 17:56 EDT, daryl herzmann
no flags Details
bt with DES_cfb64_encrypt () (9.36 KB, text/plain)
2008-06-29 18:23 EDT, daryl herzmann
no flags Details
bt with SIGPIPE (7.14 KB, text/plain)
2008-06-30 09:45 EDT, daryl herzmann
no flags Details
requested info rpm -Va and package-cleanup (14.69 KB, text/plain)
2008-06-30 12:53 EDT, daryl herzmann
no flags Details
bt in flash, NP_Shutdown () (9.45 KB, text/plain)
2008-06-30 13:00 EDT, daryl herzmann
no flags Details

  None (edit)
Description daryl herzmann 2008-06-29 17:26:30 EDT
I am probably doing something wrong on my end or perhaps shouldn't be using
Firebug, but I continue to see many crashes of firefox.  This often happens on
Javascript heavy pages like Gmail, YouTube, etc...  I'll keep attaching
backtraces I get from running 

firefox-3.0-0.beta5.6.el5

on fully updated 5.2 x86 (non fastrac)

thanks!  I'll try to find a reproducer page that doesn't require login auth...
Comment 1 daryl herzmann 2008-06-29 17:26:30 EDT
Created attachment 310542 [details]
firefox bt while on youtube mail
Comment 2 daryl herzmann 2008-06-29 17:56:18 EDT
Created attachment 310544 [details]
firefox bt with java plugin

Steps to reproduce this, I think...

1) Load applet from website.  Use it
2) Have website go away at some point
3) Attempt to load applet again.  crash
Comment 3 daryl herzmann 2008-06-29 18:23:32 EDT
Created attachment 310545 [details]
bt with DES_cfb64_encrypt ()

Just visiting www.youtube.com mainpage provoked this
Comment 4 daryl herzmann 2008-06-30 09:45:38 EDT
Created attachment 310585 [details]
bt with SIGPIPE

lockup from an internet ticketing system
Comment 5 Matěj Cepl 2008-06-30 12:30:19 EDT
I cannot reproduce this with the latest RHEL 5.2 firefox and the latest Firebug
(had to use Nightly Tester Tools to make firebug work).

Could you try to run

package-cleanup --problems
and
rpm -Va

to find out whether there is something strange with your installation, please?
Comment 6 daryl herzmann 2008-06-30 12:53:57 EDT
Created attachment 310601 [details]
requested info rpm -Va and package-cleanup

Thanks for looking into this and sorry that I can't find a clean reproducer
yet.  Will update to the nightly build of Firebug.
Comment 7 daryl herzmann 2008-06-30 13:00:02 EDT
Created attachment 310602 [details]
bt in flash,  NP_Shutdown ()

Augh,  For whatever reason, this page will crash me 100% of the time today...

http://finance.google.com/finance?q=HYGS
Comment 8 Matěj Cepl 2008-06-30 16:05:04 EDT
Whatever I do, I cannot reproduce it. Make sure you have nspluginwrapper and
libflashsupport installed, and let's try to get some more information:

what's the output of 

mozilla-plugin-config -f -c
mozilla-plugin-config -l

and

rpm -qa \*firefox\* \*plugin\* \*flash\* 

?
Comment 9 daryl herzmann 2008-06-30 16:16:14 EDT
Thank you very much for helping look into this...

I don't have mozilla-plugin-config installed and don't seem to find which
package provides it for RHEL...

# rpm -qa \*firefox\* \*plugin\* \*flash\* 
gimp-print-plugin-4.2.7-22
firefox-3.0-0.beta5.6.el5
yum-rhn-plugin-0.5.3-6.el5_2.6
firefox-debuginfo-3.0-0.beta5.6.el5
gstreamer-plugins-good-0.10.4-4.el5
acroread-plugin-8.1.2-1.el5.3
flash-plugin-9.0.124.0-1.el5
gstreamer-plugins-base-0.10.9-6.el5
java-1.5.0-ibm-plugin-1.5.0.7-1jpp.2.el5
Comment 10 Matěj Cepl 2008-06-30 16:30:40 EDT
yum install nspluginwrapper libflashsupport

But there should be new firefox coming down the pipe soon, so let's wait on it.

Let us know how it goes with the upgraded firefox then.
Comment 11 daryl herzmann 2008-06-30 16:42:03 EDT
Thanks!  Just to be clear, you want me to get libflashsupport from Fedora as I
don't see it anywhere on RHN / RHEL...
Comment 12 Matěj Cepl 2008-07-01 07:17:24 EDT
(In reply to comment #11)
> Thanks!  Just to be clear, you want me to get libflashsupport from Fedora as I
> don't see it anywhere on RHN / RHEL...

Shut, sorry, no, don't bother with libflashsupport and stay just with RHEL.
Comment 13 daryl herzmann 2008-07-21 09:40:28 EDT
Hi,

To follow up on this, I am having much better luck with firefox-3.0.1-1.el5 , so
if you want to close this as CURRENT_RELEASE, that'd be fine by me.

thanks!
  daryl

Note You need to log in before you can comment on or make changes to this bug.