Bug 453342 - yelp prints "OMF category not recognised" warning when started
yelp prints "OMF category not recognised" warning when started
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rarian (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-29 18:15 EDT by petrosyan
Modified: 2008-11-10 19:53 EST (History)
4 users (show)

See Also:
Fixed In Version: rarian-0.8.1-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-10 19:53:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 18473 None None None Never

  None (edit)
Description petrosyan 2008-06-29 18:15:53 EDT
Description of problem:
When running yelp from a terminal it prints the following warning three times:

$ yelp
OMF category 'System|Configuration|Configuration Tools' not recognised, ignoring.
OMF category 'System|Configuration|Configuration Tools' not recognised, ignoring.
OMF category 'System|Configuration|Configuration Tools' not recognised, ignoring.

Version-Release number of selected component (if applicable):
yelp-2.22.1-3.fc9.x86_64
Comment 1 Alex Lancaster 2008-07-10 21:13:50 EDT
I can reproduce this.  But worse, in my case yelp immediately quits upon this
"warning" message.
Comment 2 Matěj Cepl 2008-07-29 13:08:16 EDT
Doesn't crash, but produces messages -- yelp-2.22.1-4.fc9.i386
Comment 3 Matthew Barnes 2008-11-10 16:08:28 EST
Hmm, system-config-{dates,services,users} are the only packages (on my system, anyway) using those categories.  If anything this is a rarian issue, but the category looks valid according to

    /usr/share/librarian/Templates/C/scrollkeeper_cl.xml

Though I'm not yet sure how it all fits together.  Moving this over to rarian for now (which also belongs to me).
Comment 4 Matthew Barnes 2008-11-10 16:46:38 EST
Found the problem, opened an upstream bug:
https://bugs.freedesktop.org/show_bug.cgi?id=18473

I'll post a patch if Don doesn't beat me to it.
Comment 5 Matthew Barnes 2008-11-10 19:53:37 EST
Fixed in rarian-0.8.1-2.fc10.

Note You need to log in before you can comment on or make changes to this bug.