Bug 453388 - can't rebuild modified kernel
can't rebuild modified kernel
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Red Hat Kernel Manager
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-30 05:48 EDT by Levente Farkas
Modified: 2008-06-30 08:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-30 08:27:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2008-06-30 05:48:23 EDT
Description of problem:
currently kernel spec file (and src.rpm) contains kabi_whitelist_* which is imho
a bad practice. currently if anyone modify anything in the kernel and try to
recompile it it gives error since kabi_whitelist_* will change and does not fit
with the prepackaged files. at the same time if neither the spec file nor the
src.rpm contains these file the kernel build process will regenerate these file
anyway which is always correct and correspond to the compiled kernel. imho those
few extra seconds/minutes (to generate these files) don't important and made
ther kernel rpm and spec file more robust and flexible. so please remove it from
the spec file and from the src.rpm file (the later is important since rpmbuild
ie. the spec file look for this file in the SOURSES dir).
thanks.
Comment 1 Prarit Bhargava 2008-06-30 08:27:27 EDT
The whole point of the kabi_whitelist* is to maintain kabi consistency between
releases.


Note You need to log in before you can comment on or make changes to this bug.