Bug 453410 - vpnc does not connect and generates error messages
vpnc does not connect and generates error messages
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vpnc (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-30 09:46 EDT by C. Y. Wong
Modified: 2008-07-22 09:01 EDT (History)
2 users (show)

See Also:
Fixed In Version: Fedora 9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-22 09:01:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump from 'ausearch -m AVC' (487.98 KB, text/plain)
2008-06-30 09:49 EDT, C. Y. Wong
no flags Details
'ausearch -m AVC' dump (487.98 KB, text/plain)
2008-06-30 13:40 EDT, C. Y. Wong
no flags Details

  None (edit)
Description C. Y. Wong 2008-06-30 09:46:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061712 Fedora/3.0-1.fc9 Firefox/3.0

Description of problem:
I have been using vpnc (VPNC-0.5.1-5.fc9(i386)) in Fedora9 
(2.6.25-14.fc9.i686) successfully with no problem.  

However, recently I updated the kernel to Fedora9
(2.6.25.6-55.fc9.i686) together with many other updates last week.
Then when I start the vpnc procedure, I get the following messages:

/etc/vpnc/vpnc-script: line 99: /sbin/ip: Permission denied
/etc/vpnc/vpnc-script: line 100: /sbin/ip: Permission denied
/etc/vpnc/vpnc-script: line 104: /sbin/ifconfig: Permission denied
/etc/vpnc/vpnc-script: line 123: /sbin/ip: Permission denied
/etc/vpnc/vpnc-script: line 123: /sbin/ip: Permission denied
/etc/vpnc/vpnc-script: line 124: /sbin/ip: Permission denied
/etc/vpnc/vpnc-script: line 133: /sbin/ip: Permission denied
/etc/vpnc/vpnc-script: line 134: /sbin/ip: Permission denied
/etc/vpnc/vpnc-script: line 135: /sbin/ip: Permission denied
VPNC started in background (pid: 3127)...

and the vpnc connection did not work for the intended destination.

I tried to boot the system with the older kernel of Fedora 9
(2.6.25-14.fc9.i686), but now the same error message came out.
How do we fix this bug?

I am attaching the 'ausearch -m AVC' dump as suggested by tmraz@redhat.com
with a cc to dwash@redhat.com.

C. Y. Wong


Version-Release number of selected component (if applicable):
kernel-2.6.25.6-55.fc9(i686)

How reproducible:
Always


Steps to Reproduce:
1.I invoke vpnc as a superuser.  I have also already provided a default.conf in /etc/vpnc subdirectory.  It always worked a few weeks ago with (kernel-2.6.25-14.fc9(i686).

 

Actual Results:
2. But now, with the new upgrade to Fedora9 (2.6.25.6-55.fc9.i686), I got the above message as stated in my Description.

3.I cannot reach my intended connection using ssh or sftp. 

Expected Results:
I should be able to reach my ssh or sftp destination and tunnel to that site.


Additional info:
I am attaching the ausearch dump as suggested by tmraz@redhat.com
Comment 1 C. Y. Wong 2008-06-30 09:49:37 EDT
Created attachment 310586 [details]
dump from 'ausearch -m AVC'
Comment 2 Tomas Mraz 2008-06-30 10:26:05 EDT
Unfortunately I don't see any related AVCs in the dump. Can you try cleaning up
the /var/log/audit/audit.log file and run 'setenforce 0' and retry the vpnc
connection?
If that helps it is really SELinux related problem and has to be fixed in the
policy.

Dan, were there any recent changes related to vpnc or ip and ifconfig in SELinux
policy?
Comment 3 C. Y. Wong 2008-06-30 11:18:26 EDT
Thanks Tomas!

I clean up /var/log/audit/audit.log  and run 
/usr/sbin/setenforce 0 and then try the vpnc as suggested by Tomas.

Now, the vpnc works and the connection gets to the intended destination 
as it should.

So, it seems that this 'setenforce 0' works.   Now, I guess we fix
this 'SELinux related problem and has to be fixed in the policy'.

C.Y. Wong
Comment 4 Tomas Mraz 2008-06-30 11:39:53 EDT
Can you now attach the 'ausearch -m AVC' dump?
Comment 5 C. Y. Wong 2008-06-30 13:40:01 EDT
Created attachment 310608 [details]
 'ausearch -m AVC' dump

this is the 'ausearch -m AVC' dump attachment requested by tmraz@redhat.com.
at 2008-06-30 11:39 EST.

As I reported at 11:18 EST, the problem was rectified by doing 'setenforce 0'
and then vpnc.	 I can then get the vpnc connection to the destination as I
intended, with no error messages. But, I do not know whether you may like to
fix this problem in vpnc so that we do not need to do 'setenforce 0' every time
we use vpnc.
  

Thanks.

C. Y. Wong
Comment 6 Michal Nowak 2008-07-02 05:51:22 EDT
The weird on this is that when I issued 

    setenforce 0; vpnc; vpnc-disconnect; 

it worked and then

    setenforce 1; vpnc; vpnc-disconnect; 

it worked nice then too.

Maybe behind this is only my lack of SELinux expertise and it's expected.
Comment 7 C. Y. Wong 2008-07-02 14:22:25 EDT
I installed the latest bug-update (07/01/2008):

      selinux-policy-3.3.1.72.fc9(noarch)
and   selinuc-policy-targetd-3.3.1.72.fc9(noarch).

[I also installed the latest kernel 2.6.25.9-76.fc9(i686).  But the kernel
version probably does not seem to matter.]

I was able to connect by vpnc to the intended destination without error
messages.

It appears that this problem of "vpnc does not connect and gives error
messages" has been fixed.
Comment 8 Michal Nowak 2008-07-22 08:36:04 EDT
This disappeared somehow, close it, then, somehow too.

Note You need to log in before you can comment on or make changes to this bug.