This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 453886 - preinstall scriptlet fails if not already using i810 in xorg.conf
preinstall scriptlet fails if not already using i810 in xorg.conf
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-02 21:20 EDT by Jason Farrell
Modified: 2008-07-03 15:04 EDT (History)
3 users (show)

See Also:
Fixed In Version: xorg-x11-drv-i810-2.3.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-03 15:04:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Farrell 2008-07-02 21:20:13 EDT
Description of problem:
Updating to xorg-x11-drv-i810-2.3.2-1.fc9.x86_64 in updates-testing fails to
install because the %pre script continually fails. It tries to replace 'i810'
with 'intel' in /etc/xorg.conf, but fails completely if it doesn't match.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.3.2-1.fc9.x86_64
from
xorg-x11-drv-i810-2.2.1-24.fc9.x86_64

Additional info:
Transaction Test Succeeded
Running Transaction
sed: -e expression #1, char 41: invalid reference \1 on `s' command's RHS
error: %pre(xorg-x11-drv-i810-2.3.2-1.fc9.x86_64) scriptlet failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping xorg-x11-drv-i810-2.3.2-1.fc9
Comment 1 Michal Nowak 2008-07-03 05:23:53 EDT
I am hit by this one too.

I guess it's caused by this change

* Tue May 27 2008 Adam Jackson <ajax@redhat.com> 2.2.1-25
- s/i810/intel/ in xorg.conf in %%pre so we can eventuall stop installing
  the BC symlink.

which was useful for version prio 2.2.1-24 but it might cause the fail.
Comment 2 Michal Nowak 2008-07-03 09:58:00 EDT
Release -2 fixes this issue. New version was successfully installed.

Note You need to log in before you can comment on or make changes to this bug.