Bug 453919 - On server HP ProLiant DL380 G5 randomly freeze during boot
On server HP ProLiant DL380 G5 randomly freeze during boot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-03 04:52 EDT by Dario Lesca
Modified: 2008-07-22 12:05 EDT (History)
3 users (show)

See Also:
Fixed In Version: kernel-PAE-2.6.25.6-27.fc8.i686
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-22 12:05:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the /var/log/message file (11.24 KB, application/x-gzip)
2008-07-06 19:37 EDT, Dario Lesca
no flags Details
output debug of start_udev and settle (3.65 KB, application/x-gzip)
2008-07-07 10:42 EDT, Dario Lesca
no flags Details

  None (edit)
Description Dario Lesca 2008-07-03 04:52:54 EDT
Description of problem:

On this kind of server (HP ProLiant DL380 G5) 

> http://www.smolts.org/client/show/pub_e04ad1d7-e691-4b54-a3b6-1a5ff974d5bd

Fedora 9 (and also F8 + kernel 2.6.25 update) randomly freeze during boot

Version-Release number of selected component (if applicable):

Seem is a kernel >= 2.6.25

How reproducible:

Install Fedora 9 on HP 

Steps to Reproduce:

Install Fedora 9 on HP DL 350 G5. 

I upgraded from 2.6.25-14.fc9.i686 to 2.6.25.6-55.fc9.i686 and still had the
same problem.

Below is a snapshot from dmesg showing the problem.
I get this error:

> invalid opcode: 0000 [#1] SMP 
> Modules linked in: sg ipmi_si(+) hpwdt(+) ipmi_msghandler bnx2 button iTCO_wdt
sr_mod pcspkr iTCO_vendor_support i5000_edac edac_core cdrom ata_piix libata
cciss sd_mod scsi_mod dm_snapshot dm_zero dm_mirror dm_mod xfs uhci_hcd ohci_hcd
ehci_hcd [last unloaded: scsi_wait_scan]
> 
> Pid: 1173, comm: modprobe Not tainted (2.6.25.4-10.fc8PAE #1)
> EIP: 0060:[<f7c5edca>] EFLAGS: 00210286 CPU: 3
> EIP is at 0xf7c5edca
> EAX: 5f32335f EBX: 000f0000 ECX: 00cd0100 EDX: 00000000
> ESI: d0ffffff EDI: c39bd09b EBP: f7c5eda8 ESP: f7c5ed78
>  DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
> Process modprobe (pid: 1173, ti=f7c5e000 task=f6e08e70 task.ti=f7c5e000)
> Stack: f89c54a9 00000060 ffff007b 00200286 f7949000 ffffffed f7c5eda8 f7c5eda8 
>        c00ffee0 00000000 000f1fff c00f0000 f7c5edc8 c00f0000 c00ffee0 f7c5edc8 
>        c00f0000 f89c65d0 f89c65a0 f7949000 f7c5eddc c050659d f7949054 00000000 
> Call Trace:
>  [<f89c54a9>] ? hpwdt_init_one+0x18b/0x3a3 [hpwdt]
>  [<c050659d>] ? pci_device_probe+0x39/0x5b
>  [<c056a66b>] ? driver_probe_device+0xc0/0x137
>  [<c056a806>] ? __driver_attach+0x73/0xa9
>  [<c0569baf>] ? bus_for_each_dev+0x37/0x5c
>  [<c056a4f0>] ? driver_attach+0x14/0x16
>  [<c056a793>] ? __driver_attach+0x0/0xa9
>  [<c056a2fd>] ? bus_add_driver+0x90/0x1b7
>  [<c056a9fc>] ? driver_register+0x47/0xa2
>  [<c0506740>] ? __pci_register_driver+0x35/0x61
>  [<f89b0017>] ? hpwdt_init+0x17/0x19 [hpwdt]
>  [<c044649d>] ? sys_init_module+0x1610/0x177a
>  [<c062e63c>] ? do_page_fault+0x528/0x909
>  [<c0437238>] ? param_get_int+0x0/0x15
>  [<c0484bd3>] ? do_sync_read+0x0/0xe9
>  [<c0485896>] ? sys_read+0x3b/0x60
>  [<c0404b7a>] ? syscall_call+0x7/0xb
>  =======================
> Code: 00 ff 1f 0f 00 00 00 0f c0 c8 ed c5 f7 00 00 0f c0 e0 fe 0f c0 c8 ed c5
f7 00 00 0f c0 d0 65 9c f8 a0 65 9c f8 00 90 94 f7 dc ed <c5> f7 9d 65 50 c0 54
90 94 f7 00 00 00 00 d0 65 9c f8 f4 ed c5 
> EIP: [<f7c5edca>] 0xf7c5edca SS:ESP 0068:f7c5ed78
> ---[ end trace 732bbc392f92b3f6 ]---
> input: Ups Manufacturing RS232-USB converter as /class/input/input5
> input,hidraw0: USB HID v1.00 Gamepad [Ups Manufacturing RS232-USB converter]
on usb-0000:00:1d.2-2
> usb 4-2: New USB device found, idVendor=0a6d, idProduct=0005
> usb 4-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
> usb 4-2: Product: RS232-USB converter
> usb 4-2: Manufacturer: Ups Manufacturing
> usb 6-1: new full speed USB device using uhci_hcd and address 2
> usb 6-1: configuration #1 chosen from 1 choice
> input: HP Virtual Keyboard as /class/input/input6
> input,hidraw1: USB HID v1.01 Keyboard [HP Virtual Keyboard] on usb-0000:01:04.4-1
> input: HP Virtual Keyboard as /class/input/input7
> input,hidraw2: USB HID v1.01 Mouse [HP Virtual Keyboard] on usb-0000:01:04.4-1
> usb 6-1: New USB device found, idVendor=03f0, idProduct=1027
> usb 6-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
> usb 6-1: Product: Virtual Keyboard
> usb 6-1: Manufacturer: HP
> usb 6-2: new full speed USB device using uhci_hcd and address 3
> usb 6-2: configuration #1 chosen from 1 choice
> hub 6-2:1.0: USB hub found
> hub 6-2:1.0: 7 ports detected
> usb 6-2: New USB device found, idVendor=03f0, idProduct=1327
> usb 6-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
> usb 6-2: Product: Virtual Hub
> usb 6-2: Manufacturer: HP
> NET: Registered protocol family 10
> lo: Disabled Privacy Extensions
> ACPI: PCI Interrupt 0000:01:03.0[A] -> GSI 23 (level, low) -> IRQ 23
> device-mapper: multipath: version 1.0.5 loaded

(this errore is grab from dmesg of f8+upd)
--------------------

Below is a message from Michael to <fedora-devel-list@redhat.com>

Da: 	 Michael
A: 	 fedora-devel-list@redhat.com
Oggetto: Re: Kernel 2.6.25 (F8/F9) problem
Data: 	Wed, 2 Jul 2008 20:56:43 +0000 (GMT) (22:56 CEST)

Yesterday I installed Fedora Core 9 on three HP DL380 G5's and noticed stability
problems from the first boot. Apparently randomly one machine would boot
(fairly) normally, the other would freeze during boot and the third would tail
out stacktraces (CPU# frozen for 61secs?!). All three were fresh installs from
the same DVD on the same hardware. Rebooting the machines was a russian roulette
on which would come back up.

I upgraded from 2.6.25-14.fc9.i686 to 2.6.25.6-55.fc9.i686 and still had the
same problem on all three machines. Below is a snapshot from dmesg showing the
problem. I have just installed 2.6.26-0.98.rc8.git1.fc10.i686 and the problem
seems to have gone away.

hpwdt: New timer passed in is 30 seconds.
general protection fault: 0018 [#1] SMP
Modules linked in: ata_piix(+) joydev ipmi_si ipmi_msghandler iTCO_wdt pata_acpi
hpwdt(+) i5000_edac bnx2 serio_raw iTCO                              
_vendor_support libata edac_core button pcspkr dm_snapshot dm_zero dm_mirror
dm_mod cciss scsi_mod ext3 jbd mbcache uhci                               _hcd
ohci_hcd ehci_hcd [last unloaded: scsi_wait_scan]

Pid: 860, comm: modprobe Not tainted (2.6.25.6-55.fc9.i686 #1)
EIP: 0060:[<c0100010>] EFLAGS: 00010046 CPU: 2
EIP is at 0xc0100010
EAX: 00000018 EBX: c00ffee0 ECX: 000f1fff EDX: 00000000
ESI: f88e7608 EDI: f78d5000 EBP: f799ddd0 ESP: f799ddb0
 DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
Process modprobe (pid: 860, ti=f799d000 task=f6914000 task.ti=f799d000)
Stack: f78d5000 c00f0000 f799ddd0 c00f0000 c00ffee0 f88e757c f88e754c f78d5000
       f799dde4 c04fdfa9 f78d5054 00000000 f88e757c f799ddf8 c0561dbe f78d5054
       f78d510c f88e757c f799de0c c0561ecd f799de18 00000000 c0722310 f799de30
Call Trace:
 [<c04fdfa9>] ? pci_device_probe+0x39/0x59
 [<c0561dbe>] ? driver_probe_device+0xa0/0x136
 [<c0561ecd>] ? __driver_attach+0x79/0xaf
 [<c056176b>] ? bus_for_each_dev+0x3b/0x63
 [<c0561c63>] ? driver_attach+0x14/0x16
 [<c0561e54>] ? __driver_attach+0x0/0xaf
 [<c056113c>] ? bus_add_driver+0x9d/0x1ba
 [<c0562050>] ? driver_register+0x47/0xa7
 [<c04fe155>] ? __pci_register_driver+0x35/0x64
 [<f887a017>] ? hpwdt_init+0x17/0x19 [hpwdt]
 [<c04462f7>] ? sys_init_module+0x17be/0x18f6
 [<f88c5000>] ? iTCO_wdt_set_NO_REBOOT_bit+0x0/0x5e [iTCO_wdt]
 [<c04d2a13>] ? selinux_file_permission+0x100/0x106
 [<c04367d9>] ? param_get_int+0x0/0x15
 [<c04cb8b8>] ? security_file_permission+0xf/0x11
 [<c0482989>] ? sys_read+0x3b/0x60
 [<c0405bf2>] ? syscall_call+0x7/0xb
 [<c0620000>] ? agp_amd64_probe+0x2e4/0x3ee
 =======================
Code: 20 20 38 30 33 43 4f 4d 50 41 51 ea 00 50 00 f0 31 32 2f 33 31 2f 39 39 20
fc 00 fc f6 86 11 02 00 00 40 75 10 fa                                b8 18 00
00 00 <8e> d8 8e c0 8e e0 8e e8 8e d0 8d a6 e8 01 00 00 e8 00 00 00 00
EIP: [<c0100010>] 0xc0100010 SS:ESP 0068:f799ddb0
---[ end trace bf9a71d2e7f8ea36 ]---
BUG: sleeping function called from invalid context at kernel/rwsem.c:21
in_atomic():0, irqs_disabled():1
Pid: 860, comm: modprobe Tainted: G      D  2.6.25.6-55.fc9.i686 #1
 [<c041f5bf>] __might_sleep+0xae/0xb3
 [<c062a191>] down_read+0x15/0x29
 [<c044bcc8>] acct_collect+0x37/0x15d
 [<c0429a10>] do_exit+0x1a9/0x554
 [<c040716c>] die+0x15c/0x164
 [<c062bb5d>] do_general_protection+0x247/0x24f
 [<c0419ed8>] ? __ioremap+0x116/0x148
 [<c062b916>] ? do_general_protection+0x0/0x24f
 [<c062b1f2>] error_code+0x72/0x78
 [<c04fdfa9>] pci_device_probe+0x39/0x59
 [<c0561dbe>] driver_probe_device+0xa0/0x136
 [<c0561ecd>] __driver_attach+0x79/0xaf
 [<c056176b>] bus_for_each_dev+0x3b/0x63
 [<c0561c63>] driver_attach+0x14/0x16
 [<c0561e54>] ? __driver_attach+0x0/0xaf
 [<c056113c>] bus_add_driver+0x9d/0x1ba
 [<c0562050>] driver_register+0x47/0xa7
 [<c04fe155>] __pci_register_driver+0x35/0x64
 [<f887a017>] hpwdt_init+0x17/0x19 [hpwdt]
 [<c04462f7>] sys_init_module+0x17be/0x18f6
 [<f88c5000>] ? iTCO_wdt_set_NO_REBOOT_bit+0x0/0x5e [iTCO_wdt]
 [<c04d2a13>] ? selinux_file_permission+0x100/0x106
 [<c04367d9>] ? param_get_int+0x0/0x15
 [<c04cb8b8>] ? security_file_permission+0xf/0x11
 [<c0482989>] ? sys_read+0x3b/0x60
 [<c0405bf2>] syscall_call+0x7/0xb
 [<c0620000>] ? agp_amd64_probe+0x2e4/0x3ee
 =======================

Regards,

MC
Comment 1 Dave Jones 2008-07-03 11:59:42 EDT
I think this was a bug in the watchdog driver that should be fixed in the latest
update. Can you test that please?

anything newer than 2.6.25.7-67 should have the fix.
Comment 2 Dario Lesca 2008-07-03 13:59:40 EDT
I am out of office, then I have update the server via remote ssh with last
kernel (kernel-2.6.25.9-76.fc9.i686) and reboot the server:

after 10 minuts the server is not come alive (sig!)

[lesca@s-wallgate ~]$ ssh -v 192.168.8.115
OpenSSH_4.5p1, OpenSSL 0.9.8b 04 May 2006
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to 192.168.8.115 [192.168.8.115] port 22.
debug1: connect to address 192.168.8.115 port 22: No route to host
ssh: connect to host 192.168.8.115 port 22: No route to host

I assume that the update did not solve the problem.

Some suggest?
Comment 3 Dave Jones 2008-07-03 14:10:19 EDT
do you happen to have a serial console or similar to find out if it crashed in
the same way ?
Comment 4 Dario Lesca 2008-07-06 19:37:34 EDT
Created attachment 311109 [details]
the /var/log/message file

var/log/message file take it via rescue CD
Comment 5 Dario Lesca 2008-07-06 19:46:44 EDT
Comment on attachment 311109 [details]
the /var/log/message file

Whit new kernel the server freeze during boot when show the boot message "start
udev ...".

The attach (https://bugzilla.redhat.com/attachment.cgi?id=311109) is take from
HP server via Rescue CD.
Comment 6 Jarod Wilson 2008-07-07 09:44:48 EDT
I'm getting an F8 install onto a DL380 G5 right now...
Comment 7 Dario Lesca 2008-07-07 10:13:12 EDT
Then try update it with new kernel and reboot.

tell us what'happens.
Comment 8 Dario Lesca 2008-07-07 10:39:37 EDT
I have do some test.
see the attach.
Comment 9 Dario Lesca 2008-07-07 10:42:22 EDT
Created attachment 311164 [details]
output debug of start_udev and settle

The file attach is a collect of output of "sh -x /sbin/start_udev" and the
output of "strace -f /sbin/udevsettle" (the command witch freeze) when the
server boot with kernel 2.6.24 and 2.6.25.
In this case I have work with Fedora 8 + Update.

Hope this help.
Comment 10 Jarod Wilson 2008-07-07 15:11:32 EDT
Base F8 install (kernel 2.6.23.1): boots fine.
Base F8 install with kernel-2.6.25.9-40.fc8 installed on top: boots fine.
Base F8 install with kernel-2.6.25.9-40.fc8 and udev-118-1.fc8 installed on top:
boots fine.

Updating the rest of the OS now too, will bounce the box again once that's done.

One difference here I'm noting... The bug report is for i386, I think I actually
put an x86_64 install on the machine here. Has anyone else tried x86_64 and/or
had problems there too? If I can't reproduce any problems here (I'm going to
start stepping back through 2.6.25.x kernel builds shortly, if 2.6.25.9 still
boots okay), I suppose I should have this machine reinstalled with a 32-bit load...
Comment 11 Jarod Wilson 2008-07-07 16:13:27 EDT
Also booted fine with a fully up-to-date F8 on it. Will try an earlier 2.6.25
kernel to see if I can get it to tank, then on to a 32-bit load...
Comment 12 Jarod Wilson 2008-07-07 16:19:09 EDT
2.6.25.4-16.fc8 booted just fine too.
Comment 13 Jarod Wilson 2008-07-07 16:43:40 EDT
So I somewhat stupidly did an F9 i386 install instead of an F8 i386 install, but
right off the bat, there's the spew w/kernel-2.6.25-14.fc9.i686.

Starting udev: general protection fault: 0018 [#1] SMP 
Modules linked in: hpwdt(+) pcspkr i5000_edac edac_core dm_snapshot dm_zero
dm_mirror dm_mod cciss scsi_mod ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd
[last unloaded: scsi_wait_scan]

Pid: 1122, comm: modprobe Not tainted (2.6.25-14.fc9.i686 #1)
EIP: 0060:[<c0100010>] EFLAGS: 00010046 CPU: 0
EIP is at 0xc0100010
EAX: 00000018 EBX: c00ffee0 ECX: 000f1fff EDX: 00000000
ESI: f88dd608 EDI: f7a1b000 EBP: f7301dd0 ESP: f7301db0
 DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
Process modprobe (pid: 1122, ti=f7301000 task=f6b42000 task.ti=f7301000)
Stack: f7a1b000 c00f0000 f7301dd0 c00f0000 c00ffee0 f88dd57c f88dd54c f7a1b000 
       f7301de4 c04feac9 f7a1b054 00000000 f88dd57c f7301df8 c0562826 f7a1b054 
       f7a1b10c f88dd57c f7301e0c c0562935 f7301e18 00000000 c0723490 f7301e30 
Call Trace:
 [<c04feac9>] ? pci_device_probe+0x39/0x59
 [<c0562826>] ? driver_probe_device+0xa0/0x136
 [<c0562935>] ? __driver_attach+0x79/0xaf
 [<c05621d3>] ? bus_for_each_dev+0x3b/0x63
 [<c05626cb>] ? driver_attach+0x14/0x16
 [<c05628bc>] ? __driver_attach+0x0/0xaf
 [<c0561ba4>] ? bus_add_driver+0x9d/0x1ba
 [<c0562ab8>] ? driver_register+0x47/0xa7
 [<c047592d>] ? __vunmap+0x93/0x9b
 [<c04fec75>] ? __pci_register_driver+0x35/0x64
 [<f888e017>] ? hpwdt_init+0x17/0x19 [hpwdt]
 [<c0446f93>] ? sys_init_module+0x17be/0x18f6
 [<c04d3577>] ? selinux_file_permission+0x100/0x106
 [<c04374b1>] ? param_get_int+0x0/0x15
 [<c04cc41c>] ? security_file_permission+0xf/0x11
 [<c04835e1>] ? sys_read+0x3b/0x60
 [<c0405bf2>] ? syscall_call+0x7/0xb
 [<c0620000>] ? acpi_pci_root_add+0x22f/0x2a0
 =======================
Code: 20 20 38 30 33 43 4f 4d 50 41 51 ea 00 50 00 f0 31 32 2f 33 31 2f 39 39 20
fc 00 fc f6 86 11 02 00 00 40 75 10 fa b8 18 00 00 00 <8e> d8 8e c0 8e e0 8e e8
8e d0 8d a6 e8 01 00 00 e8 00 00 00 00 
EIP: [<c0100010>] 0xc0100010 SS:ESP 0068:f7301db0
---[ end trace d77408c1b65ae1c8 ]---
Comment 14 Jarod Wilson 2008-07-07 17:38:28 EDT
Simply blacklisting hpwdt gets 2.6.25-14.fc9.i686 booting. Installing
2.6.25.9-76.fc9.i686 now...
Comment 15 Jarod Wilson 2008-07-07 17:49:44 EDT
All's well on my end with 2.6.26.9-76.fc9.i686 running. Well, at least, the
machine booted w/hpwdt un-blacklisted, and I've encountered no spew and no
hangs. Will have to try the same 2.6.25.x F8 kernel as Dario to see if I can
reproduce the hang in udev.
Comment 16 Jarod Wilson 2008-07-07 18:00:59 EDT
That should have been 'with 2.6.25.9-76.fc9.i686 running' in the prior comment.
Things look to be okay with 2.6.25.9-40.fc8.i686 as well. Hrm. Dario, any
interesting devices in that machine that aren't in mine? Ew, lspci is long and
ugly, but here she comes...

# lspci
00:00.0 Host bridge: Intel Corporation 5000P Chipset Memory Controller Hub (rev b1)
00:02.0 PCI bridge: Intel Corporation 5000 Series Chipset PCI Express x4 Port 2
(rev b1)
00:03.0 PCI bridge: Intel Corporation 5000 Series Chipset PCI Express x4 Port 3
(rev b1)
00:04.0 PCI bridge: Intel Corporation 5000 Series Chipset PCI Express x8 Port
4-5 (rev b1)
00:05.0 PCI bridge: Intel Corporation 5000 Series Chipset PCI Express x4 Port 5
(rev b1)
00:06.0 PCI bridge: Intel Corporation 5000 Series Chipset PCI Express x8 Port
6-7 (rev b1)
00:07.0 PCI bridge: Intel Corporation 5000 Series Chipset PCI Express x4 Port 7
(rev b1)
00:10.0 Host bridge: Intel Corporation 5000 Series Chipset FSB Registers (rev b1)
00:10.1 Host bridge: Intel Corporation 5000 Series Chipset FSB Registers (rev b1)
00:10.2 Host bridge: Intel Corporation 5000 Series Chipset FSB Registers (rev b1)
00:11.0 Host bridge: Intel Corporation 5000 Series Chipset Reserved Registers
(rev b1)
00:13.0 Host bridge: Intel Corporation 5000 Series Chipset Reserved Registers
(rev b1)
00:15.0 Host bridge: Intel Corporation 5000 Series Chipset FBD Registers (rev b1)
00:16.0 Host bridge: Intel Corporation 5000 Series Chipset FBD Registers (rev b1)
00:1c.0 PCI bridge: Intel Corporation 631xESB/632xESB/3100 Chipset PCI Express
Root Port 1 (rev 09)
00:1c.1 PCI bridge: Intel Corporation 631xESB/632xESB/3100 Chipset PCI Express
Root Port 2 (rev 09)
00:1d.0 USB Controller: Intel Corporation 631xESB/632xESB/3100 Chipset UHCI USB
Controller #1 (rev 09)
00:1d.1 USB Controller: Intel Corporation 631xESB/632xESB/3100 Chipset UHCI USB
Controller #2 (rev 09)
00:1d.2 USB Controller: Intel Corporation 631xESB/632xESB/3100 Chipset UHCI USB
Controller #3 (rev 09)
00:1d.3 USB Controller: Intel Corporation 631xESB/632xESB/3100 Chipset UHCI USB
Controller #4 (rev 09)
00:1d.7 USB Controller: Intel Corporation 631xESB/632xESB/3100 Chipset EHCI USB2
Controller (rev 09)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d9)
00:1f.0 ISA bridge: Intel Corporation 631xESB/632xESB/3100 Chipset LPC Interface
Controller (rev 09)
00:1f.1 IDE interface: Intel Corporation 631xESB/632xESB IDE Controller (rev 09)
01:03.0 VGA compatible controller: ATI Technologies Inc ES1000 (rev 02)
01:04.0 System peripheral: Compaq Computer Corporation Integrated Lights Out
Controller (rev 03)
01:04.2 System peripheral: Compaq Computer Corporation Integrated Lights Out 
Processor (rev 03)
01:04.4 USB Controller: Hewlett-Packard Company Proliant iLO2 virtual USB controller
01:04.6 IPMI SMIC interface: Hewlett-Packard Company Proliant iLO2 virtual UART
02:00.0 PCI bridge: Broadcom EPB PCI-Express to PCI-X Bridge (rev c2)
03:00.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5708 Gigabit
Ethernet (rev 11)
04:00.0 PCI bridge: Broadcom EPB PCI-Express to PCI-X Bridge (rev c2)
05:00.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5708 Gigabit
Ethernet (rev 11)
06:00.0 RAID bus controller: Hewlett-Packard Company Smart Array Controller (rev 01)
09:00.0 PCI bridge: Intel Corporation 6311ESB/6321ESB PCI Express Upstream Port
(rev 01)
09:00.3 PCI bridge: Intel Corporation 6311ESB/6321ESB PCI Express to PCI-X
Bridge (rev 01)
0a:00.0 PCI bridge: Intel Corporation 6311ESB/6321ESB PCI Express Downstream
Port E1 (rev 01)
0a:01.0 PCI bridge: Intel Corporation 6311ESB/6321ESB PCI Express Downstream
Port E2 (rev 01)
0a:02.0 PCI bridge: Intel Corporation 6311ESB/6321ESB PCI Express Downstream
Port E3 (rev 01)
Comment 17 Dario Lesca 2008-07-08 13:12:10 EDT
See this:

http://www.smolts.org/client/show/pub_e04ad1d7-e691-4b54-a3b6-1a5ff974d5bd

Now I can not do a lspci.

I have install F8 respin whit 2.6.24.3-50 kernel, then update it.
Now I have 2 kernel installed and if I boot with:
2.6.24.3-50.fc8.i686 YES boot.
2.6.25.9-40.fc8.i386 NOT boot

If I install and update F8 or F9 x86_64 all work fine.

I can do some testing on the server Saturday ... any suggestions?
Comment 18 Jarod Wilson 2008-07-08 14:48:51 EDT
smolt isn't quite as detailed as lspci, but it seems these two boxes have more
or less identical hardware. That's rather annoying that I can't reproduce the
udev hang on my end. :\

So to recap progress so far, the general protection fault in the hpwdt module is
gone in 2.6.25.9, but we still have a hang when we get to udev startup, correct?
And only on a 32-bit install. At the moment, I'm tempted to reassign this bug
over to udev and see if any of the udev folks have some insight into how to
further trouble-shoot this, since the strace of the hang doesn't really give us
much to go on.

Just for clarity's sake, is the failure mode with a Fedora 9 32-bit install and
the latest updates 2.6.25.9 kernel the same as an F8 32-bit install? (I've only
tried F9 32-bit, which is fine here, so I'm wondering if this issue is specific
to F8 somehow -- maybe something in udev that is fixed in F9?).
Comment 19 Jarod Wilson 2008-07-08 15:55:56 EDT
Installing 32-bit F8 now myself...
Comment 20 Jarod Wilson 2008-07-08 17:11:44 EDT
No problems with either the initial 32-bit F8 install or a fully yum updated F8
install. Phooey.
Comment 21 Dario Lesca 2008-07-22 05:45:30 EDT
Yesterday I have update a F8 on ML380 G5 with new kernel:
  [lesca@s-vmware ~]$ uname -rv
  2.6.25.10-47.fc8PAE #1 SMP Mon Jul 7 18:32:37 EDT 2008
the system boot and all work fine.

With the previous kernel Version:
  kernel-PAE-2.6.25.6-27.fc8.i686
the server do not boot and stop on "Start Udev"

Thanks to all
Comment 22 Jarod Wilson 2008-07-22 12:05:18 EDT
Hrm. Would be good to figure out exactly what change it was that fixed things.
Just the same, will close this bug out as fixed in the current release.

Note You need to log in before you can comment on or make changes to this bug.