Bug 454135 - Anaconda crashes during installation with iSCSI target
Anaconda crashes during installation with iSCSI target
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-05 05:54 EDT by Slawomir Czarko
Modified: 2008-09-15 06:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-15 06:07:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash report generated by anaconda (83.16 KB, text/plain)
2008-07-05 05:54 EDT, Slawomir Czarko
no flags Details

  None (edit)
Description Slawomir Czarko 2008-07-05 05:54:23 EDT
Description of problem:
Anaconda crashes when pressing button to proceed to disk partitioning screen.

Version-Release number of selected component (if applicable):
11.3.0.50

How reproducible:
Always

Steps to Reproduce:
1. Boot from Fedora 8 installation DVD
2. Select installation from NFS
3. On the partitioning screen select "Custom layout"
4. Add iSCSI target
5. Exclude local disk from being used for the installation
6. Select the boot loader to be installed on iSCSI target
  
Actual results:
Anaconda crashes

Expected results:
Proceed to disk partitioning screen

Additional info:
Comment 1 Slawomir Czarko 2008-07-05 05:54:23 EDT
Created attachment 311063 [details]
Crash report generated by anaconda
Comment 2 Andy Lindeberg 2008-07-07 11:24:05 EDT
Can you try installing Fedora 9 to see if the problem appears again?
Comment 3 Slawomir Czarko 2008-07-09 08:35:51 EDT
I wasn't able to use iSCSI target with Fedora 9 at all. The same configuration 
as for Fedora 8 (installation from NFS and the same iSCSI target setup).
After adding iSCSI target the iSCSI disk doesn't appear in the list of drives 
to be used for installation. It also doesn't appear in the disk partitioning 
screen. Anaconda in FC9 doesn't report any error about iSCSI target.
Comment 4 Hans de Goede 2008-07-20 14:46:51 EDT
I've just tried reproducing the problem you see with F-9, with todays rawhide
and I couldn't reproduce this.

Can you give rawhide a try please, you can do an ftp / http install of rawhide
using the boot.iso under the images dir (xxxx/development/i386/os/images)

If you don't want to burn this to CD, you can also install from an USB-stick,
for a (short) howto see:
http://hansdegoede.livejournal.com/4573.html

Note I used a Linux machine with iscsi-target as target. Perhaps this is not an
anaconda problem, but some incompatibility between your target and Linux's iscsi 
code. If the rawhide anaconda doesn't work you can you try doing a normal (local
harddisk using) install of F-9 on a machine and then try connecting to your
iscsi target after installation?

Thanks!
Comment 5 Hans de Goede 2008-07-20 15:02:00 EDT
I now have tried to reproduce the problem you see with F-8 and that still
happens with today's rawhide's version of anaconda.

The traceback is identical (the relevant parts atleast) as the one you've
attached.
Comment 6 Hans de Goede 2008-07-20 17:14:34 EDT
Okay,

I've been analyzing the backtrace from your F-8 crash / my rawhide reproduction
and the problem is that booty (a piece of python code which configures grub
and/or lilo) does not know about the iscsi target. Which causes things to go
wrong on these 2 lines in iw/autopart_type.py:

            self.anaconda.id.bootloader.drivelist.remove(defboot)
            self.anaconda.id.bootloader.drivelist.insert(0, defboot)

Specifically the first line fails because defboot is not part of booty's
drivelist as it does not know about the iscsi disk.

I think that since our diskset can hold special disks like iscsi we should add a
check to our _fillBootStore if booty knows about the disk before adding it to
our bootstore and thus the "What drive would you like to boot from" pull down
menu. That would fix this backtrace (by not allowing to select to boot from the
iscsi disk) if we really want to allow booting from iscsi (see below) then we
should tell booty about the iscsi disk when it is added.

Slawomir, do you really have hardware which can boot from an iscsi disk, iow the
bios or an add in card rom supports iscsi? According to this page:
http://technomagesinc.com/iscsi_faq.html

(which was the most informative page I can find on booting from iscsi) iscsi
booting isn't really a normal wel supported thing todo.
Comment 7 Slawomir Czarko 2008-07-23 03:34:25 EDT
I don't have a hardware which can boot from an iscsi disk. I was installing F-8 
on a computer with an existing Linux installation.
I wanted to remove the internal SATA disk from the drive list to avoid 
accidentally messing up the existing installation. After finishing installation 
on iscsi target I copied the kernel image etc. to the SATA disk and added a new 
boot menu entry for grub on the SATA disk.
Btw, I used a Linux machine with iscsi-target as target.
Should I still try rawhide installation of F-9?
Comment 8 Hans de Goede 2008-07-23 03:39:21 EDT
(In reply to comment #7)
> I don't have a hardware which can boot from an iscsi disk. I was installing F-8 
> on a computer with an existing Linux installation.
> I wanted to remove the internal SATA disk from the drive list to avoid 
> accidentally messing up the existing installation.

I see, so removing the iscsi disk from the list of devices to choose from where
to install the bootloader seems to be a good solution then, as that will avoid
the backtrace you've seen.

> Should I still try rawhide installation of F-9?

As you were using an linux iscsi target, no. That works fine in rawhide, so
whatever problem you were seeing with F-9 was either a configuration error on
your side or has been fixed now.
Comment 9 Hans de Goede 2008-08-07 05:16:16 EDT
Just a quick note for those following this bug, I'm on this I know how to fix this and codify it. The problem is I'm just starting as an Anaconda developer (and I officially don't start until Sept 1st) and I yet have to setup my development environment.

I'll be going on vacation for a week now, after that I'll implement a fix which removes the iscsi device from the install bootloader on ... dropdown. Actually it will remove any devices not known to booty.
Comment 10 Hans de Goede 2008-09-15 06:07:47 EDT
I've commited a fix (as described in comment #6) to git now, this will get picked up in the next anaconda rawhide build, closing.

Note You need to log in before you can comment on or make changes to this bug.