Bug 454184 - kmix doesn't start on login
kmix doesn't start on login
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-06 01:58 EDT by Jonathan Kamens
Modified: 2015-01-14 18:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-05 21:23:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2008-07-06 01:58:52 EDT
I'm running all current packages from Rawhide as of 7/6/2008.  I have
kdemultimedia-4.0.84-1.fc10.

Kmix doesn't start when I log in.  It is listed in the Session Preferences
dialog (System > Preferences > Personal > Sessions).

Here's what ~/.xsession-errors has to say about "grep kmix"):

** (gnome-session:3739): DEBUG: read /usr/share/autostart/kmix_autostart.desktop
** (gnome-session:3739): DEBUG: read
/usr/share/autostart/restore_kmix_volumes.desktop
** (gnome-session:3739): DEBUG: app kmix_autostart.desktop not installed or not
for GNOME
** (gnome-session:3739): DEBUG: app restore_kmix_volumes.desktop not installed
or not for GNOME
** (gnome-session-properties:4737): DEBUG: read
/usr/share/autostart/kmix_autostart.desktop
** (gnome-session-properties:4737): DEBUG: read
/usr/share/autostart/restore_kmix_volumes.desktop
** (gnome-session-properties:4850): DEBUG: read
/usr/share/autostart/kmix_autostart.desktop
** (gnome-session-properties:4850): DEBUG: read
/usr/share/autostart/restore_kmix_volumes.desktop

I don't know what to make of this.
Comment 1 Kevin Kofler 2008-07-06 14:28:12 EDT
gnome-session? Are you running GNOME? If so, it's normal that KMix doesn't 
start, it's set to autostart only in KDE.
Comment 2 Jonathan Kamens 2008-07-06 19:21:24 EDT
If it's normal for it not to auto-start, then why is it listed as one of the
Startup programs in System > Preferences > Personal > Sessions?

And if kmix isn't what I'm supposed to be using in GNOME as my volume control,
what *should* I be using.  There needs to be *something* that starts
automatically when I log in and puts a volume control in my system tray, doesn't
there?
Comment 3 Kevin Kofler 2008-07-06 19:30:07 EDT
None of these are problems in kdemultimedia.
Comment 4 Jonathan Kamens 2008-07-29 14:26:46 EDT
Perhaps not a kdemultimedia bug, but definitely a bug somewhere, since this used
to do the right thing and doesn't anymore, and "Sessions Preferences" clearly
indicates that kmix is supposed to be starting on login but it isn't.

Perhaps a gnome-desktop bug?
Comment 5 Rex Dieter 2008-07-29 14:28:28 EDT
All the way up to F-9 at least, /usr/share/autostart was a kde-only thing.  Is
gnome (in rawhide) using that now too?
Comment 6 Jonathan Kamens 2008-07-29 14:31:53 EDT
I have no idea what gnome is using.  All I know is that kmix used to start
automatically every time I logged in; it is no longer starting automatically
even though my session preferences say that it's supposed to; and I didn't
change anything to cause this change in behavior.

Clearly there needs to be a way to get a volume control in the system tray
automatically upon login.  If there's another way to do it other than what kmix
used to do for me, I'd love to hear what it is, but I still maintain that
there's a bug here.
Comment 7 Ray Strode [halfline] 2008-07-30 09:59:48 EDT
Hi Jonathan,

right click on your panel, choose "Add to Panel" and pick "Volume Control". 
That should give you want you want, I think.

Rex, looking at rawhide gnome-session, I see:

      g_ptr_array_add (dirs, 
                       g_build_filename (system_data_dirs[i], 
                                         "autostart", NULL));

which is clearly wrong.  Jon, do you know why it's doing this? 
/usr/share/autostart is a kde specific directory with kde specific semantics
that are different than /etc/xdg/autostart
Comment 8 Ray Strode [halfline] 2008-07-30 10:00:56 EDT
For clarity, when I mentioned Jon above I meant Jon McCann (who I added to the
cc list) not Jonathan Kamens.
Comment 9 Rex Dieter 2008-07-30 10:13:23 EDT
fwiw, /usr/share/autostart is fixable either way, I just need to know what to
expect from gnome (though selfishly, I'd prefer the old behavior, less work you
know).
Comment 10 Ray Strode [halfline] 2008-07-30 17:57:12 EDT
Nah, this is an old topic that's been beat in the ground before. 
/usr/share/autostart was explicitly ignored when the xdg autostart idea was made
because it has different existing semantics than what were being proposed.  It's
a bug that gnome-session is trying to use it.
Comment 11 Matthias Clasen 2008-08-01 09:53:45 EDT
Here is what I committed upstream, it'll show up in rawhide in a bit.

2008-08-01  Matthias Clasen  <mclasen@redhat.com>

        * gnome-session/gsm-util.c (gsm_util_get_autostart_dirs): Don't
        look in /usr/share/autostart, since that is a KDE-specific
        location using legacy KDE autostart conventions predating the
        autostart spec.
Comment 12 Jonathan Kamens 2008-08-06 21:55:09 EDT
Do I understand correctly that the "fix" for this problem is not that I will once again be able to get kmix to start automatically upon login under GNOME, as I could before, but rather than it no longer appears in the "Session Preferences" dialog?

This is not the "fix" I was looking for.  I like kmix a lot better than the GNOME volume control applet, I liked being able to use it in GNOME, and I was hoping to be able to once again use it in GNOME.  Is that not going to happen?
Comment 13 Matthias Clasen 2008-08-06 22:03:56 EDT
You can use kmix, of course. You just have to install an autostart file in a place where gnome-session looks: /etc/xdg/autostart, /usr/share/gnome/autostart
or ~/.config/autostart.
Comment 14 Jonathan Kamens 2008-08-06 22:12:13 EDT
Is there a tool somewhere for generating such a file, or documentation somewhere of what to put in it, or do I need to guess by looking at other autostart files?  Thanks.
Comment 15 Kevin Kofler 2008-08-06 22:18:41 EDT
Try copying the file from /usr/share/autostart maybe?
Comment 16 Matthias Clasen 2008-08-06 22:21:20 EDT
I think you can use the Add button in the session capplet to create one

Note You need to log in before you can comment on or make changes to this bug.