This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 454185 - vino-server doesn't start on login
vino-server doesn't start on login
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vino (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-06 02:02 EDT by Jonathan Kamens
Modified: 2013-03-05 22:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-01 00:58:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2008-07-06 02:02:22 EDT
System > Preferences > Internet and Network > Remote Desktop claims that remote
desktop is enabled, but vino-server doesn't start when I log in.

I have all current packages from Rawhide, including vino-2.22.2-1.fc9.

There is nothing in ~/.xsession-errors explaining why it doesn't start.

When I run it by hand, I can then successfully connect to my desktop remotely.
Comment 1 Stewart Adam 2008-07-18 12:20:04 EDT
I can confirm both the issue and the workaround, manually running
/usr/libexec/vino-server solves the problem.

rpm -ql reveals that vino seems to start itself using bonobo .server file, but
the same files are present in the fc9 and fc10 versions of vino. Maybe this is a
bonobo issue?
Comment 2 Matthias Clasen 2008-07-25 12:38:28 EDT
Should be fixed in tomorrows rawhide.
Comment 3 Jonathan Kamens 2008-07-29 14:28:21 EDT
I have vino-2.23.5-2.fc10, as well as all other packages current from rawhide,
and vino didn't start on login, right after a clean reboot of the machine.
Comment 4 Matthias Clasen 2008-08-01 00:58:20 EDT
Please  try with 2.23.5-3.fc10 tomorrow. My build had failed...

Note You need to log in before you can comment on or make changes to this bug.