Bug 454264 - file supportinfo differs between x86_64 and i386 by new line
file supportinfo differs between x86_64 and i386 by new line
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: redhat-release (Show other bugs)
4.7
All Linux
low Severity low
: beta
: ---
Assigned To: Nick Petrov
Alexander Todorov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-07 06:54 EDT by Alexander Todorov
Modified: 2009-05-18 16:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:28:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-07-07 06:54:00 EDT
Description of problem:
File /var/lib/supportinfo differs between x86_64 and i386 by a new line.

Version-Release number of selected component (if applicable):
redhat-release-4WS-8

How reproducible:
always

Steps to Reproduce:
1. Diff the file contents from i386 and x86_64 package

  
Actual results:
--- /tmp/rpmdf/inputs/after/i386/redhat-release/payload/var/lib/supportinfo
2008-07-02 15:22:57.000000000 -0400
+++ /tmp/rpmdf/inputs/after/x86_64/redhat-release/payload/var/lib/supportinfo
2008-07-02 15:22:56.000000000 -0400
@@ -7,3 +7,4 @@
 Variant: WS
 MinRAM: 256 MB
 MaxCPU:	2
+


Expected results:
Files do not differ

Additional info:
Comment 2 Daniel Mach 2008-07-07 07:31:28 EDT
Does this apply also for other variants or is it WS only issue?

I'd like to close it as WONTFIX, since it's a minor glitch and redhat-release is
not (and will never be) a multilib package.
Comment 3 Alexander Todorov 2008-07-07 07:47:19 EDT
Seems like other variants have the new lines correct. Only WS has additional new
line for x86_64.

WONTFIX is not acceptable for QE. This is an easy fix and not fixing it will
results in unnecessary rpmdiff warnings which QE has to inspect manually and
waive every time. If redhat-release is never meant to be multilib just fix the
new line so that the multilib test case in rpmdiff reports the correct result.
Do not try to work around the problem please.

4.8 is OK for QE though.
Comment 8 Alexander Todorov 2009-02-24 10:17:38 EST
VERIFIED with redhat-release-4AS-8.3
Comment 10 errata-xmlrpc 2009-05-18 16:28:37 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1002.html

Note You need to log in before you can comment on or make changes to this bug.