Bug 454268 - Cannot connect to Windows shared folders
Cannot connect to Windows shared folders
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Simo Sorce
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-07 07:22 EDT by antonio montagnani
Modified: 2008-09-20 07:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-20 07:52:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description antonio montagnani 2008-07-07 07:22:09 EDT
Description of problem:
I cannot connect to shared folders on Windows machines

Version-Release number of selected component (if applicable):
samba-3.2.0-1.rc2.16.fc10.i386

How reproducible:
always

Steps to Reproduce:
1.try to connect to a Windows shared
2.
3.
  
Actual results:
I can see the shared folder on the Windows machine (the list I mean) but when I
click on each of it I get the request for a password (why??) and then the
message that position cannot be mounted - DBus error
org.freedesktop.DBus.Error.InvalidArgs: Mountpoint Already registered

Expected results:
Position should be mounted smoothly as in F9

Additional info:
Comment 1 antonio montagnani 2008-07-10 06:57:19 EDT
smbclient -L //celeron
Enter antonio's password: 
Anonymous login successful
Domain=[WORKGROUP] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

	Sharename       Type      Comment
	---------       ----      -------
cli_rpc_pipe_open: cli_nt_create failed on pipe \srvsvc to machine celeron. 
Error was NT_STATUS_ACCESS_DENIED
Error returning browse list: NT_STATUS_ACCESS_DENIED
Anonymous login successful
Domain=[WORKGROUP] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

	Server               Comment
	---------            -------
	CELERON              Celeron
	CONTEC               Samba Server Version 3.2.0-17.fc9
	PC-CONTECSRL         

	Workgroup            Master
	---------            -------
	WORKGROUP            CELERON
Comment 2 Simo Sorce 2008-09-03 08:47:32 EDT
Rawhide now has version 3.2.3, can you confirm this still happens against it?
It shouldn't.
Comment 3 antonio montagnani 2008-09-03 08:56:30 EDT
samba-3.2.1-0.19.fc10.i386 on my system....
smbclient -L //celeron
Enter antonio's password: 
Domain=[CELERON] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

	Sharename       Type      Comment
	---------       ----      -------
	IPC$            IPC       IPC remoto
	print$          Disk      Driver della stampante
	EPSONSty        Printer   EPSON Stylus Photo 915
	Documenti       Disk      
	HPLaserJ        Printer   Hp su Celeron
	Volume (F)      Disk      
	Immagini        Disk      
Domain=[CELERON] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

	Server               Comment
	---------            -------

	Workgroup            Master
	---------            -------

But if I open Resources/Network I don't see the Windows folders on CELERON machine, and it is fine in F9). Maybe a different component to blame???
Comment 4 antonio montagnani 2008-09-03 09:03:23 EDT
I don't see version 3.2.3 in the development repo. Am I missing something???
Comment 5 Simo Sorce 2008-09-03 09:21:41 EDT
Can you access a specific share through smbclient ?
Comment 6 antonio montagnani 2008-09-03 09:48:09 EDT
 smbclient \\\\Celeron\\Documenti
Enter antonio's password: 
Domain=[CELERON] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]
smb: \> ls
  .                                  DR        0  Thu Sep  7 11:42:09 2006
  ..                                 DR        0  Thu Sep  7 11:42:09 2006
  2-Jartest.doc                       A    84992  Mon Feb 21 15:39:53 2005
  22marzo02                           D        0  Wed Sep  1 16:45:10 2004
  Aurat JSC - Russia                  D        0  Wed Mar 16 09:50:10 2005
  Basic engineering                   D        0  Thu Oct 28 11:51:11 2004
  bozze di contratti                  D        0  Mon Oct 11 17:20:14 2004
  Brochures                           D        0  Tue Jun  5 10:46:30 2007
  chlorine_table_g1.gif               A    44641  Tue Feb 15 10:55:29 2005
  confronto reattori prezzi.xls       A    14848  Mon Feb 14 10:53:19 2005
  dati pr3.xls                        A    81408  Mon Feb 14 10:29:16 2005
  desktop.ini                       AHS       62  Tue Aug 31 10:40:27 2004
  Disegni fanali                      D        0  Wed Sep  1 13:45:38 2004
  Documenti generici PAC              D        0  Mon Oct 11 17:21:31 2004
  Documenti master contec             D        0  Fri Sep 29 13:31:05 2006
  Documenti tecnici master            D        0  Tue Nov 28 16:25:14 2006
  economico liquido.xls               A    16896  Thu Feb 24 16:19:26 2005
  economico solido.xls                A    16384  Wed Mar  9 15:52:03 2005
  economico.xls                       A    17408  Fri Jan 14 12:46:57 2005
  economico1.xls                      A    18432  Fri Jan 14 14:57:29 2005
  economico2.xls                      A    18432  Mon Feb  7 16:45:50 2005
  Fatture                             D        0  Wed Mar 16 09:54:30 2005
  foto impianto                       D        0  Wed Mar 16 09:54:31 2005
  Gujarat                             D        0  Wed Apr 13 11:06:33 2005
  hp pump.doc.tif                     A   250536  Tue Sep 14 14:39:47 2004
  market.xls                          A    30720  Thu Mar  3 13:31:54 2005
  Musica                             DR        0  Tue Mar  1 16:32:28 2005
  Offerte                             D        0  Wed Mar 16 09:55:49 2005
  PAC engineering                     D        0  Wed Mar 16 09:56:01 2005
  PR3 engineering design              D        0  Wed Mar 16 09:56:07 2005
  PR3 enginnering design              D        0  Fri Dec 17 10:58:06 2004
  Rendiconti spese                    D        0  Wed Mar 16 09:47:40 2005
  Romania-SBS                         D        0  Thu Jan 19 12:31:55 2006
  Sandro personale                    D        0  Wed Mar 16 09:47:41 2005
  specifiche apparecchi               D        0  Mon Oct 11 17:21:30 2004
  Thumbs.db                                 4608  Tue Aug 31 16:09:17 2004
  V-301                               D        0  Mon Oct 11 17:21:30 2004
  Varie                               D        0  Wed Mar 16 09:47:41 2005
  Venezuela                           D        0  Wed Mar 16 09:47:44 2005
  Video                              DR        0  Tue Mar  1 16:33:53 2005

		58635 blocks of size 1048576. 42385 blocks available

I can access shared folder by smbclient....
Comment 7 antonio montagnani 2008-09-04 08:13:19 EDT
Some improvement after this morning updates, now I can see shard folder graphically but I get same error as x comment #1 dated July 7.
Was that rawhide already F9 or F10???
Comment 8 antonio montagnani 2008-09-04 08:18:09 EDT
And I suppose that it is in some way connected to the fact that I am not able to print on a windows shared printer.
Comment 9 antonio montagnani 2008-09-05 06:45:11 EDT
I also note that now from a F10 I cannot see the F9 public folders on another computer but I can see from F9 computer the public folder on F10 computer.
Comment 10 antonio montagnani 2008-09-19 05:43:48 EDT
Since this morning I can login to  Windows shared folders....still I can't print on Windows shared printer.
So I think that this bug might be closed (and another one filed for printer sharing...

Note You need to log in before you can comment on or make changes to this bug.