Bug 454296 - Compatibility support for previous releases
Compatibility support for previous releases
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: compat-gcc-32 (Show other bugs)
5.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks: 391501
  Show dependency treegraph
 
Reported: 2008-07-07 11:19 EDT by Alan Matsuoka
Modified: 2010-10-22 22:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-07 11:32:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Matsuoka 2008-07-07 11:19:59 EDT
Description of problem:
We are testing our app with RHEL5.1 x86_64, but some parts of the app are still
compiled on RHEL3 i386. These worked fine on RHEL4 i386 with the compat libs. I
see that RHEL5.1 does not have compat libs for RHEL3. I just wanted to check on
the official backwards compatibility policy of Red Hat. It looks like it is one
release back is supported, but not two. Is that correct? Thanks!

How reproducible:
.n.a

Version-Release number of selected component (if applicable):
5.1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:

Additional Info:

We guarantee core libraries for n+2

compat-glibc-2.3.2-95.30 is not in RHEL5.

Since we do support stuff to N+2 then is should be in there. I tried building it
but I got
compat-gcc-32 >= 3.2.3 is needed by compat-glibc-2.3.2-95.30.i386
compat-gcc-32 >= 3.2.1-5 is needed by compat-glibc-2.3.2-95.30.i38

compat-gcc-32 is also not available for RHEL5 but compat-gcc-32-3.2.3-61.src.rpm
is available on the RHEL5.2 SRPM DVD.
Comment 1 Jakub Jelinek 2008-07-07 11:32:07 EDT
We guarantee runtime compatibility for n-2, but definitely not (and never did)
guarantee devel compatibility for n-2, only (selected parts of) n-1.
compat-glibc is devel only package (headers and linker stub for linking),
so it is ok that RHEL3 glibc isn't covered in RHEL5.  RHEL5 glibc (which is the
runtime package) supports RHEL2.1/RHEL3/RHEL4/RHEL5 linked programs and shared
libraries (as long as they don't invoke undefined behavior of course).

In RHEL5 from compat-gcc-32 src.rpm we just build the needed runtime library
package (compat-libstdc++-33).

Note You need to log in before you can comment on or make changes to this bug.