Bug 454381 - nm-applet always chooses "Auto eth0", regardless of nm-connection-editor settings
nm-applet always chooses "Auto eth0", regardless of nm-connection-editor sett...
Status: CLOSED DUPLICATE of bug 485555
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-08 00:27 EDT by James Hunt
Modified: 2009-03-03 15:49 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-03 15:49:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Hunt 2008-07-08 00:27:11 EDT
Description of problem:

Summary pretty much says it all. I have configured 1 wired connection and 1
wireless connection using "nm-connection-editor". However, on every boot,
nm-applet decides that it knows best and creates an "Auto eth0" which --
unsurprisingly -- doesn't do what I want (it gets the DNS search paths in
/etc/resolv.conf incorrect amongst other things).

Version-Release number of selected component (if applicable):

NetworkManager-0.7.0-0.9.4.svn3675.fc9.i386

How reproducible:

Every time.

Steps to Reproduce:

1. Run, nm-connection-editor or (nm-applet->right click->edit connections) as
   a non-privileged user and set up some connections.
2. Ensure that the connections have the "connect automatically" box ticked.
3. Reboot

Aside: took me a while to realize that the connections you create when running
nm-connection-editor as root are *not* the ones nm-applet will use - it appears
to *only* use the users configured connections.
  
Actual results:

NM creates an "Auto eth0" connection using dhcp, ignoring the 2 connections I
have created and actually want it to use.

Expected results:

NM should use my connections basically.

Additional info:

# /sbin/chkconfig --list|egrep -i "network"
NetworkManager  0:off   1:off   2:on    3:on    4:on    5:on    6:off
network         0:off   1:off   2:off   3:off   4:off   5:off   6:off
#
Comment 1 James Hunt 2008-07-13 16:38:27 EDT
Please see bug 454368 for some weirdness that seems related to the problem
documented here.
Comment 2 Bob Fay 2008-11-25 15:04:59 EST
This problem also exists in Fedora 10, NetworkManager-0.7.0-0.11.svn4229.fc10.  

I have a laptop with both wired and wireless interfaces.  Using the NetworkManager applet I edit the eth0 interface to use "Automatic addresses only" on the IPv4 tab.  I provide addresses for DNS servers and some search domains.  I do likewise for the wireless interface.  The settings are remembered when I log out and back in, when I suspend and resume, when I restart the NetworkManager service but not when I reboot the system.  After a reboot the wireless settings remain but the settings for eth0 return to the fully automatic setting. 

This makes it difficult to configure local dns caching and/or OpenDNS.
Comment 3 Deependra Singh Shekhawat 2008-11-30 22:12:06 EST
Hi,

Yes I am facing a similar issue. I have a desktop machine with F10 installed. And NetworkManager is at version

NetworkManager-0.7.0-0.12.svn4326.fc10

I created a wired network connection with static IP and switched to it but as soon as I logout and log back in NetworkManager chooses the 'System eth0' connection which defaults to DHCP (which I don't want to use for this particular system).

I went desperate enough to make this work but finally saw that I can't delete the network connection 'System eth0' from the connection editor.

Also note that my custom created connection in the editor is also set to connect to it automatically. 

Thanks
Comment 4 Bob Fay 2008-12-01 16:48:32 EST
On my system the behavior has changed with the update to NetworkManager version 0.7.0-0.12-svn4326.fc10 from version 0.7.0-0.11-svn4229.fc10.  Previously, as described above, it was possible to "edit" the Auto eth0 connection in the NetworkManager Applet.  This is no longer the case, everything for Auto eth0 is now grayed out.  Not sure if this change is due to something new in the newer version of NetworkManager or maybe the old behavior that I observed was related to the fact that my system was originally built with Fedora 10 Release Candidate and then upgraded to the final version.
Comment 5 Bob Fay 2008-12-01 21:40:48 EST
I found a solution.  As root run system-config-network (or launch it via the menu option "System>Administration>Network"). Edit eth0, on the General tab check the option "Controlled by NetworkManager". Save the change.  Reboot (I'm not sure if that's really necessary.)  When you log back in to the system, eth0 will not be connected. Right click on the NetworkManager applet and select Edit Connections.  Add a new connection, configure it as needed for your requirements (note you do not have to supply a MAC address). After you save the new connection and Close the Network Connections window, NetworkManager should attempt to use the new connection.  The new connection should persist after a system reboot.
Comment 6 Ryan Bonham 2009-01-01 17:09:54 EST
I can confirm this behavior on Fedora 10. NetworkManager ignore user created connections and defaults to Auto Eth0 on boot.
Comment 7 Dan Williams 2009-03-03 15:49:34 EST
Dupe-ing since the fix for bug 485555 will make the operation of the "Auto eth0" connection clearer, though it won't make NM magically start controlling connections where NM_CONTROLLED=no.

*** This bug has been marked as a duplicate of bug 485555 ***

Note You need to log in before you can comment on or make changes to this bug.