Bug 454649 - Searching koji doesnt work very well
Searching koji doesnt work very well
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: koji (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
http://koji.fedoraproject.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-09 11:10 EDT by James Begley
Modified: 2013-01-09 20:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-09 11:38:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Begley 2008-07-09 11:10:20 EDT
Description of problem:

Searching the koji website doesnt work very well.  You need to know the exact 
name for the builds that you are searching for.  Eg a search for 'bluez' shows 
no results, and you have to know to search for 'bluez-util' or 'bluez-libs'.  
Also a search for a specific rpm fails, eg searching for 'bluez-utils-alsa' 
returns no results (since its part of the 'bluez-utils' package).  All of this 
means that searching the koji website isn't particularly useful.  I would hope 
that a search for 'bluez' would show some useful information.

I guess that this should be filed as an enhancement directly with koji, but 
since I can't work the koji trac system (I guess it should be available at 
https://fedorahosted.org/koji/newticket but it isnt there for me) I've given up 
and filed it here.
Comment 1 Jesse Keating 2008-07-09 11:38:23 EDT
Koji searching supports globs:

http://koji.fedoraproject.org/koji/search?match=glob&type=package&terms=bluez*

As for searching for packages, you can use the dropdown box to move from
searching packages to rpms

http://koji.fedoraproject.org/koji/search?match=glob&type=rpm&terms=bluez-utils-alsa*

Note You need to log in before you can comment on or make changes to this bug.