Bug 454795 - CPUSCALING test never pass on HP Compaq 2510p notebook
CPUSCALING test never pass on HP Compaq 2510p notebook
Status: CLOSED NOTABUG
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
All Linux
low Severity low
: ---
: ---
Assigned To: Greg Nichols
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-09 22:53 EDT by YangKun
Modified: 2008-08-21 11:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-21 11:23:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the result.xml file (148.65 KB, text/xml)
2008-07-09 22:54 EDT, YangKun
no flags Details
sysreport tarball (670.38 KB, application/x-bzip2)
2008-07-09 22:56 EDT, YangKun
no flags Details

  None (edit)
Description YangKun 2008-07-09 22:53:46 EDT
Description of problem:

this test never pass on HP Compaq 2510p notebook, I tried the latest hts-5.2-18
on RHEL5.2-i386, also failed.
Comment 1 YangKun 2008-07-09 22:54:22 EDT
Created attachment 311438 [details]
the result.xml file
Comment 2 YangKun 2008-07-09 22:56:55 EDT
Created attachment 311439 [details]
sysreport tarball
Comment 3 Greg Nichols 2008-07-10 11:12:49 EDT
Please try setting the speeds manually:

> cpufreq-selector -f 1068
> cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq
> cpufreq-selector -f 1067
> cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq
Comment 4 YangKun 2008-07-10 21:41:20 EDT
seems cpufreq-selector not working:

===============================================================
[root@dhcp-65-124 ~]# cpufreq-selector -f 1068
[root@dhcp-65-124 ~]# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq 
800000
[root@dhcp-65-124 ~]# cpufreq-selector -f 1067
[root@dhcp-65-124 ~]# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq 
800000
[root@dhcp-65-124 ~]# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor 
userspace
[root@dhcp-65-124 ~]# cat
/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors 
ondemand userspace performance 
[root@dhcp-65-124 ~]# cat
/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies 
1068000 1067000 800000 
[root@dhcp-65-124 ~]# echo "ondemand" >
/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
[root@dhcp-65-124 ~]# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor 
ondemand
[root@dhcp-65-124 ~]# cpufreq-selector -f 1068
[root@dhcp-65-124 ~]# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq
800000
[root@dhcp-65-124 ~]#
===============================================================
Comment 5 Greg Nichols 2008-07-11 10:45:20 EDT
I'd say the test really does fail. 

One more thing: could you try:

> cpufreq-selector -f 1068000

I'm wondering if it's a units problem MHz vs KHz.
Comment 6 YangKun 2008-07-13 21:27:05 EDT
looks like it is a MHz vs KHz problem:

===============================================================
[root@dhcp-65-124 ~]# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq 
800000
[root@dhcp-65-124 ~]# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor 
ondemand
[root@dhcp-65-124 ~]# cpufreq-selector -f 1068000
[root@dhcp-65-124 ~]# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq 
1067000
[root@dhcp-65-124 ~]# cat
/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies 
1068000 1067000 800000 
[root@dhcp-65-124 ~]# cpufreq-selector -f 1068000
[root@dhcp-65-124 ~]# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq 
1067000
[root@dhcp-65-124 ~]# cpufreq-selector -f 1067000
[root@dhcp-65-124 ~]# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq 
1067000
[root@dhcp-65-124 ~]# cpufreq-selector -f 800000
[root@dhcp-65-124 ~]# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq 
800000
[root@dhcp-65-124 ~]#
===============================================================

so does this mean this laptop can not be certified since it fails this
cpuscaling test ?
Comment 7 Greg Nichols 2008-07-14 07:45:46 EDT
So the conclusion is that 1068000 KHz is stated as an available frequency, but
it can't be set.   It's clearly a test failure (not an HTS bug).

Note You need to log in before you can comment on or make changes to this bug.