Bug 454822 - LTC:4.8:201497:AACRAID Driver poor RAID1 write performance
LTC:4.8:201497:AACRAID Driver poor RAID1 write performance
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.8
x86_64 All
high Severity high
: beta
: 4.9
Assigned To: Rob Evers
Martin Jenner
: FutureFeature, HardwareEnablement, OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-10 00:02 EDT by IBM Bug Proxy
Modified: 2010-10-22 22:43 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 13:52:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 46230 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-07-10 00:02:25 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-07-09 17:30 EDT
1. Feature Id:	[201497]
Feature Name:	AACRAID Driver Update
Sponsor:	xSeries
Category:	Device Drivers and IO
Request Type:	Driver - Update Version

2. Short Description
An updated version of aacraid driver is required to address several bug fixes and enhancements.

3. Business Case
The aacraid driver is used across the System x product line. We need the in-distro driver to be as
current as possible so known critical bugs are ensured to be corrected.


4. Sponsor Priority	1
IBM Confidential:	no
Code Contribution:	IBM code
Upstream Acceptance:	Accepted
Component Version Target:	Driver Update
Performance Assistance:	

5. PM Contact:	Monte Knutson, mknutson@us.ibm.com, 877-894-1495

6. Technical contact(s):
Kevin Stansell, kstansel@us.ibm.com
Chris McDermott, mcdermoc@us.ibm.com

7. LTC Manager: Julio Alvarez, julioa@us.ibm.com
Comment 1 IBM Bug Proxy 2008-08-28 17:50:34 EDT
There are minor patches and bug fixes to the driver upstream. Peter will be
providing the backports later next week.
Comment 2 RHEL Product and Program Management 2008-09-03 08:58:19 EDT
Updating PM score.
Comment 3 Andrius Benokraitis 2008-09-08 17:20:27 EDT
Note to IBM: Since Mark Salyzyn's departure from Adaptec, feedback from Adaptec has since been spotty. A driver update in RHEL 4.8 may require more attention from you all until the transition has been solidified. 

Adaptec's catch-all user 'aacraid@adaptec.com' has been added to this bug for their assistance.
Comment 4 Philip Pokorny 2008-09-29 20:56:31 EDT
Similar BZ/update needs to be done for RHEL 5 which is currently using an even older aacraid version.

Current version at www.adaptec.com is 1.1-5[2459]
Comment 7 Tom Coughlan 2008-10-03 16:22:10 EDT
The aacraid driver appears to have been abandoned by Adaptec. 

We will consider this request when there is a patch available, and there appears  to be adequate resources to support this hardware.
Comment 8 Philip Pokorny 2008-10-03 22:59:30 EDT
Why would you say that?  As recently as August 1st, they released an updated driver for a wide variety of distro kernels:

http://www.adaptec.com/en-US/downloads/linux_source/linux_source_code?productId=SAS-5445&dn=Adaptec+RAID+5445

How could they possibly abandon the driver for their major product?
Comment 9 Achim Leubner 2008-10-06 05:04:47 EDT
Comment #7 is absolutely not true.  Of course we continue supporting the aacraid driver. There was a lot of transition work because Mark Salyzyn is no longer with Adaptec. But I will cover all open issues as soon as possible.

Achim Leubner
Senior Software Engineer / RAID drivers
Adaptec Inc.
Comment 10 Tom Coughlan 2008-11-25 14:43:31 EST
The latest that we can accept patches for 4.8, in order for us to meet our internal deadlines is Dec. 4. At this stage in the life of RHEL 4, the highest priority is to avoid regression. Patches must be very low risk, targeted at fixing specific bugs.
Comment 14 Bryn M. Reeves 2008-12-19 09:26:11 EST
Have a report of poor write performance on a RAID1 array configured on an IBM x3400 blade with a ServeRAID controller:

03:00.0 RAID bus controller: Adaptec AAC-RAID (Rocket) (rev 02)

       ServeRAID0: kernel 5.1-0[9237]
       ServeRAID0: monitor 5.1-0[9237]
       ServeRAID0: bios 5.1-0[9237]
       ServeRAID0: serial 600bc000

       Hard disk configuration:
       Dv:Bx:Slot    Model              Rev     Speed      Size
       00:00:00      IBM-ESXSGNA146C3   BH0D    3,0Go/s    136,7Go
       01:00:01      IBM-ESXSGNA146C3   BH0D    3,0Go/s    136,7Go
 
       RAID configuration:

       Array HW     : RAID1    Type RAID1
       Array Size   : 136,7 Go
       Array Status : OKAY
       Write Cache  : Disable
       Read  Cache  : Disable 

I was able to reproduce similar behaviour on an x3755 equipped with a similar controller/array configuration that was completely addressed by updating to aacraid 1.1.5-2455.

The original reporter does not see any improvement on this driver version, nor when updating firmware to the latest provided by their hardware vendor:

   ServeRAID0: kernel 5.2-0[15411] Oct 11 2007
   ServeRAID0: monitor 5.2-0[15411]
   ServeRAID0: bios 5.2-0[15411]
   ServeRAID0: serial 600BC000

Reporter states that 2.6.19 is affected by the problem but their testing of distributions based on 2.6.22 and later see good write performance to the array.
Comment 16 Andrius Benokraitis 2009-01-08 12:58:43 EST
Adaptec: The code is long overdue (see Comment #10). Do you have any updated code proposed for RHEL 4.8? If not, this bugzilla will eventually get closed, and will run the risk of aacraid not getting updated for the remainder of RHEL 4.
Comment 17 Achim Leubner 2009-01-09 05:30:54 EST
Sorry for the delay. We're working on that.
Comment 18 Andrius Benokraitis 2009-01-09 13:46:35 EST
Achim - thanks - please have the code posted here ASAP so that it may make Beta.
Comment 19 IBM Bug Proxy 2009-02-23 15:21:13 EST
Hi,

According to a recent RHEL4.8 alpha install, the aacraid driver currently in RHEL4.8 is:  Adaptec aacraid driver 1.1-5[2455].    It appears that the driver has still not been updated to the latest Adaptec driver.

# uname -a
Linux elm3c55.beaverton.ibm.com 2.6.9-81.ELsmp #1 SMP Wed Feb 11 12:43:52 EST 2009 x86_64 x86_64 x86_64 GNU/Linux
# cat /etc/*release*
Red Hat Enterprise Linux AS release 4 (Nahant Update 8 Beta)

Adaptec -- do you have an ETA on when you'll deliver the RHEL 4.8 driver?

Thanks.
Comment 20 Andrius Benokraitis 2009-02-23 15:37:24 EST
IBM - despite 5+ months of promises from Adaptec to update aacraid, no action has been taken on their part.

That being said, we are past the point for accepting wholesale driver updates in RHEL 4.8. We can only accept specific patches that resolve specific defects at this point.

I'm leaning towards closing this bug entirely, and only entertaining specific defects that need addressing if they arise.
Comment 21 Achim Leubner 2009-02-24 06:04:35 EST
I'm sorry about this impression. The latest driver in scsi-misc-2.6 (kernel 2.6.29-rc1) is 2456 with small changes to the RHEL4.8 driver version 2455. Our latest driver version is 2460 but not yet included in the latest Linux kernels. In my understanding RedHat only accepts driver updates to versions also included in the latest Linux kernels. Therefore I assumed 2455 is fine with RHEL4.8.
Our next step will be providing a patch to the community for the latest 2.6 kernel to update the driver to 2460. Of course we also provide driver packages for the different Linux distributions. 
We really want to avoid such problems in the future. Please clarify what updates and patches you accept and anticipate for future releases.

Many thanks
Comment 22 IBM Bug Proxy 2009-02-26 01:30:32 EST
Hi All,

FYI, I ran diskdump on this particular driver on SystemX, and i confirm it passes successfully.

-Rishi


The above test has been run on following :

Distro version: RHEL4.8 Alpha.
kernel :  2.6.9-81.ELsmp

-Rishi
Comment 24 Tom Coughlan 2009-03-27 18:00:05 EDT
(In reply to comment #21)

> We really want to avoid such problems in the future. Please clarify what
> updates and patches you accept and anticipate for future releases.

You are quite correct, we generally require that code is upstream before we accept it in to RHEL. It is also the case that, as the release matures, we prefer to take small, specific fixes for bugs, rather than wholesale drive updates. So, as you stated, there is no need to make a small update to driver in RHEL 4, just for the sake of matching what is upstream (2460). It is also not desirable to rush the next large upstream update (2460) in to RHEL 4.8. 

The reason this BZ became testy is 

1) IBM indicated that they needed an update "to address several bug fixes and enhancements". 

It would have been most helpful if someone from Adaptec had promptly pointed out to them that there is no update available in the 4.8 timeframe, and then asked them to be very specific about the bugs they need fixed. I suspect we would have found out that this was a generic place-holder request.  

2) There was a customer report of poor write performance on a RAID1 array configured on an IBM x3400 blade with a ServeRAID controller (comment 14). If this were investigated in a timely manner, it is likely that a specific fix for something like this would be appropriate for 4.8. Instead there has been no reply from Adaptec. 

I think the next step is for Adaptec and/or IBM to try to reproduce the problem, or ask for more information.  The report indicates that an upgrade from 2.6.19 to 2.6.22 solves the problem, so I assume that a diff between those will provide some suggestions on what to try. 

I will move this BZ to 4.9, so we can address the problem in comment 14 when it is understood.
Comment 26 Rob Evers 2009-08-20 13:17:44 EDT
Achim,

Do you have any plans to provide a patch for this?

Rob
Comment 27 Rob Evers 2009-09-02 13:52:16 EDT
A fix for this problem is considered inappropriate for rhel4 this late in the life-cycle of the release.

Note You need to log in before you can comment on or make changes to this bug.