Bug 45484 - named not OK with broken /etc/named.conf
named not OK with broken /etc/named.conf
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-21 18:30 EDT by Stacy Pennington
Modified: 2007-04-18 12:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-21 18:31:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stacy Pennington 2001-06-21 18:30:58 EDT
Description of Problem:
If an error exists in the /etc/named.conf file, running the "service named
start" command, causes an "OK" message for starting the service. In
actuality, the service is not started, so it is not "OK".

How Reproducible:
Always

Steps to Reproduce:
1. Stop named (type "service named stop" as root)
2. Open the previous working /etc/named.conf in an editor and add some
random text. Save the file.
3. Start named (type "service named start" as root)
You will see OK but the service is not running. The error is correctly
posted in /var/log/messages

Actual Results:
The service is not started when the user thinks it is started.

Expected Results:
The service should report back that it "Failed" letting the user know that
it is not running.

Additional Information:
Comment 1 Bernhard Rosenkraenzer 2001-07-19 06:40:24 EDT
The problem is that the named parent process returns 0 even if the config 
files are broken (because the config files are parsed later by the various 
child processes).
I've added a workaround to the startup scripts in 9.1.3-3.
Comment 2 Karl schmidt 2001-07-30 13:40:36 EDT
I can confir this bug
Comment 3 Charles Curley 2001-09-27 12:06:55 EDT
Perhaps users should use named-checkconf to test their configurations instead of
re-starting the server? I sure wish I'd known about it when I upgraded from bind
8 to 9.
Comment 4 Karl schmidt 2001-09-28 01:23:44 EDT
Yes both named-checkconf and named-checkzone are useful - but that is not the 
bug here - this bug most often shows up in linuxconf thinking that named is not 
running when it really is and tries to start a second copy.

Note You need to log in before you can comment on or make changes to this bug.