Bug 454897 - Building newsx agains dyn. inn libraries, if inn-2.4.5-2 is avail. in rawhide.
Building newsx agains dyn. inn libraries, if inn-2.4.5-2 is avail. in rawhide.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: newsx (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dominik 'Rathann' Mierzejewski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-10 12:53 EDT by Jochen Schmitt
Modified: 2008-07-14 13:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-14 13:16:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jochen Schmitt 2008-07-10 12:53:58 EDT
On BZ #453993 I have force a rework of the inn packages, so no static libraries
may be installed on the system. Instead there are dynamic libraries agains which
you should build your application.

So it will be nice, if you may rebuild your package after inn-2.4.5-2 or later
may be available in rawhide

Best Regards:

Jochen Schmitt
Comment 1 Dominik 'Rathann' Mierzejewski 2008-07-12 18:13:11 EDT
Will the inn packages be rebuilt without static libs in F-9 and F-8 too?
Comment 2 Dominik 'Rathann' Mierzejewski 2008-07-12 18:57:25 EDT
Fixed in newsx-1.6-9.fc10
(http://koji.fedoraproject.org/koji/taskinfo?taskID=712263)
Comment 3 Jochen Schmitt 2008-07-13 14:05:43 EDT
We will not rebuild the inn packages for F-9 and F-8 becouse this may coused a
incompatiblity issue which is not allowed by the update policy.
Comment 4 Dominik 'Rathann' Mierzejewski 2008-07-13 14:58:55 EDT
What kind of incompatibilites does that change introduce? I don't see any.
Removing static libs from inn package (while keeping shared ones) does no harm
to current packages (they already have inn libs linked in statically). And
rebuilding all packages that BuildRequire: inn-devel should not cause any problems.
Comment 5 Jochen Schmitt 2008-07-13 15:22:35 EDT
Of corse, I normally doesn't exprected any issues, but be aware, that this is a
build agains inn-2.4.5 and F-9 and F-8 contains inn-2.4.4 in thier repositories.

But to do no update meems ti be on the save side.
Comment 6 Dominik 'Rathann' Mierzejewski 2008-07-14 13:16:57 EDT
OK then, closing as FIXED RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.