Bug 45499 - .font resources ignored when compiling --with-xfs
.font resources ignored when compiling --with-xfs
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xemacs (Show other bugs)
7.1
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-22 06:45 EDT by Ville Skyttä
Modified: 2007-03-26 23:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-22 06:47:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for menubar and popup fonts (493 bytes, patch)
2001-06-22 06:47 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2001-06-22 06:45:58 EDT
Description of Problem:

When XEmacs is compiled with --with-xfs (at least xemacs-21.1.14-10 for 7.1
seems to be), .font resources are ignored in favor of .fontSet resources.
See /usr/share/xemacs-21.1.14/etc/Emacs.ad or etc/Emacs.ad in the source
tarball, lines 187->

This causes some ugly-looking fonts to be used in XEmacs' menubars and
popups. Applying the attached patch to
/usr/share/xemacs-21.1.14/etc/Emacs.ad and doing xrdb -merge with it fixes
the fonts. I haven't tried recompiling with the patch, but as is said in
the beginning of Emacs.ad, the resources in the file should be compiled in.

How Reproducible:
Always

Steps to Reproduce:
1. Start xemacs
Comment 1 Ville Skyttä 2001-06-22 06:47:27 EDT
Created attachment 21545 [details]
Fix for menubar and popup fonts
Comment 2 Trond Eivind Glomsrxd 2001-06-22 11:07:45 EDT
Added to xemacs-21.1.14-14 - thanks for your patch.
Comment 3 Jean-Jacques Duchene 2001-07-24 07:55:57 EDT
I am facing the same problem, and I have tried to apply the patch
in the attachment (adding *menubar*FontSet and popup*FontSet to
X resources and loading them with xrdb). But I have got a warning telling
that it was unable to build a FontSet with: 
-*-helvetica-bold-r-*-*-*-120-*-*-*-*-iso8859-*
and I still have some ugly courier font in menus. I am probably missing
something... but what ?
Comment 4 Jean-Jacques Duchene 2001-09-03 08:01:37 EDT
As there is no answer to my previous comment, some more info:
the line:
*menubar*FontSet: -*-helvetica-bold-r-*-*-*-120-*-*-*-*-iso8859-*
leads to this message:
Warning: Missing charsets in String to FontSet conversion 
Warning: Cannot convert string "-*-helvetica-bold-r-*-*-*-120-*-*-*-*-iso8859-*"
to type FontSet 
This seems to be due to the LANG variable, which is by default fr_FR@euro
with Redhat 7.1 for France (I think that iso8859-15 encoding, not iso8859-1, is
used with fr_FR@euro, which may cause the problem).
So your patch will not fix the problem for most european users using their
default locale...
Workarounds which worked for me: either set LANG to fr_FR instead of fr_FR@euro,
or use true type fonts which have more charsets.

Note You need to log in before you can comment on or make changes to this bug.