Bug 455002 - Please rebuild subcommander to fix broken deps in rawhide + open up ACLs
Please rebuild subcommander to fix broken deps in rawhide + open up ACLs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: subcommander (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
: Reopened
Depends On: 455189 455191
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-11 07:37 EDT by Alex Lancaster
Modified: 2008-07-17 12:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-17 12:00:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2008-07-11 07:37:30 EDT
subcommander has been on the rawhide broken deps list for a while now.  It
needs to be rebuilt for a new .soname bump:

Broken deps for i386
----------------------------------------------------------
    subcommander-1.9.93-2.fc10.i386 requires libsvn_ra_dav-1.so.0

I would fix this but the ACLs are locked down.  Would you consider opening up
the ACLs so that other Fedora maintainers could fix this package?  Thanks.
Comment 1 Jochen Schmitt 2008-07-13 14:02:57 EDT
Should be fixed in 1.9.93-3.fc10.

I have deleted the pkg.acl file. I hope this may open the ACLs.
Comment 2 Jochen Schmitt 2008-07-13 16:25:31 EDT
Unfortunately, there are some issue with the build which depends on the packages
apr-devel and apr-util-devel
Comment 3 Alex Lancaster 2008-07-13 18:09:26 EDT
(In reply to comment #1)
> Should be fixed in 1.9.93-3.fc10.
> 
> I have deleted the pkg.acl file. I hope this may open the ACLs.

That doesn't work anymore, you have to manage the package via PackageDB now:

https://fedoraproject.org/wiki/Infrastructure/SOP/PackageDB

For subcommander here is the page:

https://admin.fedoraproject.org/pkgdb/packages/name/subcommander

Looks like you have opened up all the branches except for Fedora 9 (select the
checkbox "group members can commit").
Comment 4 Alex Lancaster 2008-07-13 18:12:44 EDT
(In reply to comment #2)
> Unfortunately, there are some issue with the build which depends on the packages
> apr-devel and apr-util-devel

No, it looks simpler than that, according to:

http://koji.fedoraproject.org/koji/getfile?taskID=712861&name=build.log

atch #2 (subcommander-2.0.0b3-var.patch):
+ /bin/cat /builddir/build/SOURCES/subcommander-2.0.0b3-var.patch
+ /usr/bin/patch -s -p0 --fuzz=0
patch unexpectedly ends in middle of line
2 out of 2 hunks FAILED -- saving rejects to file util/Stackframe.cpp.rej

the patch is failing to apply, so you'll probably need to investigate why the
patch is failing.
Comment 5 Jochen Schmitt 2008-07-14 10:20:47 EDT
Sorry, the patch-fuzz issue I have fixed. But there are some issues with the 
configure.ac file which needs to run autoconf agains subcommander. But this is 
only possibly, if the reported bugs agains apr-devel and apr-util-devel are 
solved.

As an addtional information from the upstream, there is a bug in subversion-1.5 
which couse a crash of subcommander.

Hi Jochen,

thanks for your patch :)

Unfortunately subversion 1.5.0 has a compatibility bug which crashes 
subcommander when running a commit. :(

I created a patch that was applied in subversion r31944. So subcommander will 
need at least 1.5.1. Which does not yet exist..
Comment 6 Jochen Schmitt 2008-07-17 12:00:30 EDT
Fix in subcommander-1.9.93-5.fc10

Note You need to log in before you can comment on or make changes to this bug.