Bug 455064 - Move the self-signed CA serialno file
Move the self-signed CA serialno file
Status: CLOSED ERRATA
Product: freeIPA
Classification: Community
Component: ipa-server (Show other bugs)
1.0
All Linux
low Severity low
: ---
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
Depends On:
Blocks: 453489
  Show dependency treegraph
 
Reported: 2008-07-11 15:16 EDT by Rob Crittenden
Modified: 2015-01-04 18:33 EST (History)
3 users (show)

See Also:
Fixed In Version: freeipa-2.0.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
move the serialno file (4.25 KB, patch)
2008-07-24 14:45 EDT, Rob Crittenden
no flags Details | Diff

  None (edit)
Description Rob Crittenden 2008-07-11 15:16:52 EDT
Description of problem:

The file /usr/share/ipa/serialno contains the last issued serial number of the
self-signed CA.

Since this file can change at runtime it should instead be in /var/lib/ipa.

This file is not controlled by rpm so we can handle moving it in an rpm %post
Comment 1 Rob Crittenden 2008-07-24 14:45:05 EDT
Created attachment 312586 [details]
move the serialno file
Comment 2 Rob Crittenden 2008-07-25 09:14:07 EDT
master: a19d27717aef5089d35f589be7726e5627d1469b
Comment 3 Jenny Galipeau 2008-11-25 08:44:04 EST
Fix verified:

[root@jennyv3 /]# ls /var/lib/ipa
ca_serialno  sysrestore

[root@jennyv3 /]# more /var/lib/ipa/ca_serialno 
1003

Note You need to log in before you can comment on or make changes to this bug.