Bug 455089 - /dev/dri/card* is given root only permission.
/dev/dri/card* is given root only permission.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
:
Depends On:
Blocks: 364381
  Show dependency treegraph
 
Reported: 2008-07-11 17:26 EDT by Luugi Marsan
Modified: 2009-06-20 00:53 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
* libdrm, the direct rendering module, had its file permissions set to allow use only by root. This meant that unless xorg.conf were edited specifically to allow drm access, non-root users could not access /dev/dri/card0 and therefore could not use accelerated 3D with the fglrx driver for ATI video cards. In this update, libdrm has been patched to allow non-root users to access the module. In turn, this allows non-root users to take advantage of the 3D acceleration features of these cards without having to manually configure xorg.conf to do so.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:29:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X server log file (62.14 KB, text/plain)
2008-07-24 11:49 EDT, Luugi Marsan
no flags Details
xorg.conf file used with fglrx driver (2.58 KB, text/plain)
2008-07-24 11:50 EDT, Luugi Marsan
no flags Details

  None (edit)
Description Luugi Marsan 2008-07-11 17:26:32 EDT
Description of problem:

Non root users do not have permission to use DRM unless the xorg.conf file is 
edited to set the proper permission. Other distributions including Fedora, 
patch the libdrm module to allow non-root users to access /dev/dri/card0 which 
in turns allows accelerated 3D with the fglrx driver. Is there any chance that 
you will change this policy in the near future? We have users complaining of 
this extra step, so we want to have a clear understanding of your intentions to 
probably relay the information to them. 



Version-Release number of selected component (if applicable):
RHEL 5.2

steps to reproduce: 
 1- startx with radeon or fgrlx driver installed. 

 2- ls -l /dev/dri/card0

 3- Check file permission. 

The file permission are currently 660. Is this expected?  Fedora 9 and other 
distributions will have permissions set to 666 since they patch libdrm to allow 
non-root users to access /dev/dri/card*.
Comment 1 Matěj Cepl 2008-07-15 19:32:24 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Luugi Marsan 2008-07-24 11:49:02 EDT
Created attachment 312573 [details]
X server log file
Comment 4 Luugi Marsan 2008-07-24 11:50:14 EDT
Created attachment 312574 [details]
xorg.conf file used with fglrx driver
Comment 5 Luugi Marsan 2008-07-24 11:54:40 EDT
(In reply to comment #1)
> Thanks for the bug report.  We have reviewed the information you have provided
> above, and there is some additional information we require that will be helpful
> in our diagnosis of this issue.
> 
> Please attach your X server config file (/etc/X11/xorg.conf) and X server log
> file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
> attachments using the bugzilla file attachment link below.
> 
> Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
> let X11 autodetect your display and video card? Attach to this bug
> /var/log/Xorg.0.log from this attempt as well, please.
> 
> We will review this issue again once you've had a chance to attach this
information.
> 
> Thanks in advance.

The xserver will not start without an xorg.conf file since I'm using a R600. card. 
Comment 7 Kevin E. Martin 2008-08-14 15:55:55 EDT
Luugi, the log file you've attached is from X11R6.8.2, which is not used in RHEL5.  Is this a bug in RHEL4, RHEL5, or both?
Comment 8 Russell Doty 2008-08-19 16:15:31 EDT
AMD, can you answer the question in comment #7?
Comment 9 Luugi Marsan 2008-08-19 17:17:57 EDT
(In reply to comment #7)
> Luugi, the log file you've attached is from X11R6.8.2, which is not used in
> RHEL5.  Is this a bug in RHEL4, RHEL5, or both?


Both. RHEL4 and RHEL5.
Comment 10 Russell Doty 2008-08-19 17:25:51 EDT
We will need separate Bugzilla entries for RHEL 5 and RHEL 4. The usual way of handling this sort of request is to implement in RHEL 5 and then backport to RHEL 4.

So, let's get this nailed down for RHEL 5 and then clone the BZ for RHEL 4.

Kevin, what information do you need to get this resolved for RHEL 5?
Comment 11 Dave Airlie 2008-09-11 23:44:12 EDT
can we get QA ack for this, I've built the fix into

xorg-x11-server-1.1.1-48.48.el5

already.

bug moved to server from libdrm.
Comment 13 Adam Jackson 2008-09-12 11:47:04 EDT
Built in 1.1.1-48.48.el5.  MODIFIED.
Comment 16 Ruediger Landmann 2009-01-07 21:00:53 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
* libdrm, the direct rendering module, had its file permissions set to allow use only by root. This meant that unless xorg.conf were edited specifically to allow drm access, non-root users could not access /dev/dri/card0 and therefore could not use accelerated 3D with the fglrx driver for ATI video cards. In this update, libdrm has been patched to allow non-root users to access the module. In turn, this allows non-root users to take advantage of the 3D acceleration features of these cards without having to manually configure xorg.conf to do so.
Comment 17 errata-xmlrpc 2009-01-20 16:29:24 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0162.html

Note You need to log in before you can comment on or make changes to this bug.